Jump to content
Sign in to follow this  
bigworm

? about pixel color get

Recommended Posts

bigworm

heres my script so far.

WinActivate ( "2Moons" )
WinWaitActive ( "2Moons" )

While 1
    Sleep (5000)
    Send ("L")
    Sleep (1000)
    MouseClick ("left")
    Sleep (1000)
    $begin = TimerInit()

    While 1
        $dif = TimerDiff($begin)
        If $dif > 20000 Then Exitloop
        
        $Color = PixelGetColor(124, 145)
        if ($Color == 0x3569B8) Then
            MouseDown("left")
            While 1
                $Color = PixelGetColor(124, 145) 
            if ($Color == 0xBC0000) Then
                    MouseUp("left")
                    ExitLoop
                eNDiF
            Wend
        EndIf
    Wend
Wend

this is a fishbot ive been putting together, its suppose to see when the bar is blue and holds down left mouse button, then when it turns red it releases. i used a nice autoit script to get the colors and cords. so thats all correct, i hope. i think maybe my script is wrong. maybe i missed something. if anyone could check it over i would appreciate it and any feed back ty.

Share this post


Link to post
Share on other sites
bigworm

i thought i would add in that it seems to hit the F key just fine but for some reason it wont hold down the mouse key. just curious if anyone can let me know if i did the script wrong im till really new and it would be nice to have some feed back ty.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.