Jump to content
Sign in to follow this  
TriPham

Modal Javascript Prompt in IE

Recommended Posts

TriPham

I'm evaluating AutoItv3 and ran into a modal dialog prompt problem in IE.

I have a Javascript prompt in my web page to get some info from the user, when I use AutoIt, it can click the button and bring up the prompt but it seems like the script will pause until the prompt goes away.

I've tried from _IEAttach($DialogTitle, "DialogBox") to Send, ControlSend, WinGetHandle but none work.

I put in a couple MsgBox() to see where it fail and found that AutoIt pauses right when the modal dialog box displays.

The javascript is a very simple script:

ret = prompt('Enter Your Name:', "");

Have any body experience with this problem before and is there any solution?

Thanks

Share this post


Link to post
Share on other sites
DaleHohm

Please see the second example for the _IEAction function in the latest release.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
TriPham

Please see the second example for the _IEAction function in the latest release.

Dale

There's only 1 example for the _IEAction function (v3.2)

If you meant the second example in _IEAttach(), that didn't work either. Also, Javascript popup is not a "Internet Explorer_Server1" type so this function wouldn't work either, and I tried it.

The problem is that the script wouldn't execute any statement until the modal popup prompt is closed. Is that a bug/limitation in v3.2?

-Thanks

Share this post


Link to post
Share on other sites
DaleHohm

V3.2 is not the latest version.


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.