Sign in to follow this  
Followers 0
kvua

My Autoit script

4 posts in this topic

Alright,

I work for a major university, the autoit program that I made is basically a program installer. The programs are ones offered through the university for students. They are stored on flash drives that my workers use to install them on students computers. Until now, everything was working fine with XP. And then Microsoft dropped Vista on us.

What my program does is that it looks inside of a predefined folder for the program, launches the executable and then proceeds to install the program without user interaction. This was on a XP machine. Now, Vista hinders this process and when I run the program, it errors out and doesn't run the program at all. The other concern is that when I do get to run it, it prompts me to allow or continue all the time when installing the software. Is there any way to disable this feature on vista so I can install the software and then turn it back on?

I could really use any help.

Thank you,

Curt

Share this post


Link to post
Share on other sites



That would be User Account Control getting in your way. You can turn it off or on in the User Accounts control panel.

Share this post


Link to post
Share on other sites

Add

#RequireAdmin

to the top of the script. You will only be prompted once.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Can you post the script then we can help you

Edited by Tiger

My UDFs:- _RegEnumKey

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0