Sign in to follow this  
Followers 0
Helomotorola

FileInstall not active if "source" or "dest" include "-" ?

8 posts in this topic

#1 ·  Posted (edited)

FileInstall not active if "source" or "dest" include "-" ?

It'll not intall though "source" in file *.exe

FileInstall("C:\Exam-ple\Source.ini", "C:\Program Files\Exam-ple\Dest.ini")

Thank

Edited by Helomotorola

Share this post


Link to post
Share on other sites



FileInstall not active if "source" or "dest" include "-" ?

It'll not intall though "source" in file *.exe

Thank

The FileInstall() source cannot contain any variables or wildcards (as stated very clearly in the help file). Literal hyphens in the literal source path are no problem. The destination can contain variables and macros:

$FileName = @ComputerName & "-1.exe"
FileInstall("C:\Sources\Files\My-File-1.exe", @ScriptDir & "\" & $FileName)

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Please don't take this wrong, but that didn't make sense. May I ask what you're native language is if its not English? Can you try something for me and see if this help you and others that don't speak good English?

Bring up a second browser windows and visit http://www.google.com/language_tools and under "Translate" pick your language to English. If you're language isn't listed at google's translation site give this other one a try http://www.faganfinder.com/translate/ If that doesn't work for you you can always look through the 3+ pages of translation sites listed at http://www.babblefish.com/babblefish/freetranslation.php

Once you've found a translation site, type your question there without the code and copy the English text here. Might not be perfect or great, but I'm hoping it'll be better than what we have now. Remember don't translate your code, just your question. You can post your code directly in here as you've been doing.

Tell us the language you speak and I'll try to find you a translation page. Can't promise it'll work since I can't test your language :)

Share this post


Link to post
Share on other sites

Please don't take this wrong, but that didn't make sense. May I ask what you're native language is if its not English? Can you try something for me and see if this help you and others that don't speak good English?

Bring up a second browser windows and visit http://www.google.com/language_tools and under "Translate" pick your language to English. If you're language isn't listed at google's translation site give this other one a try http://www.faganfinder.com/translate/ If that doesn't work for you you can always look through the 3+ pages of translation sites listed at http://www.babblefish.com/babblefish/freetranslation.php

Once you've found a translation site, type your question there without the code and copy the English text here. Might not be perfect or great, but I'm hoping it'll be better than what we have now. Remember don't translate your code, just your question. You can post your code directly in here as you've been doing.

Tell us the language you speak and I'll try to find you a translation page. Can't promise it'll work since I can't test your language :)

Is there one for ebonics? That would make this site go much smoother :)

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

Sorry!

I'm from Vietnam

Share this post


Link to post
Share on other sites

What is misunderstood? The OP is saying that a problem is happening with FileInstall not working with a hyphen in it.

Please post info on the version of AutoIt you are using.

Share this post


Link to post
Share on other sites

I had try with new vertion but not active. It's not intall though *.exe still contain "source"

Share this post


Link to post
Share on other sites

What is misunderstood? The OP is saying that a problem is happening with FileInstall not working with a hyphen in it.

Please post info on the version of AutoIt you are using.

Nothing was misunderstood from the OP... I was speaking in general.

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0