Sign in to follow this  
Followers 0
jgus

Using with Zenworks

5 posts in this topic

I have a very simple install for a program. All it requires is clicking on one OK button to finish the install. So for an AutoIt3 script I just use the following commands. This works great I can run it fine directly as an .au3 file or compile it into a .exe file and everything works fine. But when I try creating a Zenworks application that points to the .exe file it throws some error message. I also tried pointing the app to the autoit3.exe file and use the .au3 script as the switch/parameter. I also tried pointing the zen app to the c:\KB832414_MSXML2.5_x86.exe file and then I had just the WinWaitActive and Send commands run in a script from the "Launch Scripts" section of Zenworks. I'm not at work now so I can't give the exact error message.

Can someone please explain exactly how this should be used in zenworks?

Run("c:\KB832414_MSXML2.5_x86.exe /Q")

WinWaitActive("Microsoft Data Access Components Hotfix Installer")

Send("{ENTER}")

Share this post


Link to post
Share on other sites



Maybe you could explain what Zenworks is... I have never heard of it. It sounds as though you are putting AutoIt commands into a program called Zenworks? I dont quite understand how or what it is that you are wanting.

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

If you don't know what Novell's Zenworks is then you probably won't be able to help me with the issue. I need someone who has used AutoIt3 with Zenworks. Thanks anyway though.

Share this post


Link to post
Share on other sites

If you don't know what Novell's Zenworks is then you probably won't be able to help me with the issue.  I need someone who has used AutoIt3 with Zenworks.  Thanks anyway though.

<{POST_SNAPBACK}>

Oh okay I see... sorry that I cant be of any assistance. :)

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

No....I am fully logged in. I am just manually running the application from the Novell Application Launcher. Like I said I know the script works fine on it's own. The issue is using it through a Zenworks application.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0