Sign in to follow this  
Followers 0
mbrown

Inactive Button

3 posts in this topic

I don't know if anyone has tried to automate the Avaya Modular Messaging install. But, it has one window that is up at all times that shows the progress of the install and then I suppose it executes the other boxes like Installation Options and Choose your Language. That main progress window is named Avaya Modular Messaging along with another screen that comes up where you need to click Next and then fill out the user information. The problem I am running into is that the first Next button is grayed out for about 10 seconds and then it is activated so that you can click on it. I am having the script wait 35 seconds before it proceeds since I am running this install on a very fast machine (compared to the ones that actually need to have it installed). How can have the script watch for the button becoming active?

Share this post


Link to post
Share on other sites



While ControlCommand("title", "text", controlID, "IsEnabled", "") = 0

Sleep(250)

WEnd


"be smart, drink your wine"

Share this post


Link to post
Share on other sites

While ControlCommand("title", "text", controlID, "IsEnabled", "") = 0

Sleep(250)

WEnd

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0