Sign in to follow this  
Followers 0
nikolajp

Richtext Objects.. I need some help please?

5 posts in this topic

I have coded an application using one of the Richtextbox examples posted in this forums.

I use the following procedure:

$oRP = ObjCreate("RICHTEXT.RichtextCtrl.1")

$GUIActiveX = GUICtrlCreateObj( $oRP, 10, 10 , 400 , 260 )

GUICtrlSetPos($GUIActiveX,10,10,300,160)

It works perfectly on my development machine, but on a VMware machine it fails to show the textbox.

I recieve an error, when I try the AutoIT example RichText script (same procedure as mine).

It says the COM object is not licensed.

I have then tried registering the richtx32.ocx with regsvr32 a(with a boot), but it is still failing.

Is there a way to supply the file in the install-dir and tell AutoIt to use this?

What am I supposed to do to make this work? (and why is it happening).

Do I need a speciel .NET version or something? (I believe both PCs are fully updated).

The windows versions are XP SP2 and fully registered with a corporate license.

I have tried the RichText procedure made by GaryFrost - I recoded the messagebox and this version displays the text-box (Good job Gary!), but the highlighting/font change does not work. My problem is, that I cannot figure out how to change the font/color in this way of doing it. It is too complex I'm afraid. I also need to read the contents of the box, which is not completed yet I think.

Share this post


Link to post
Share on other sites



Is the richtx32.ocx component present at all most likely in system, system32 or in local path? AND is it the same revision?

kjactive :)

Yes, it is present.

I have tried copying the file from the working computer to the system32 folder on the failing VMware machine with no result. It says the file is not licensed..

Could this be dependant on an Office installation? I'm trying to install Office2003 now to see if it should fix it.

Any other suggestions?

Share this post


Link to post
Share on other sites

The richtext object has been there since before Office. It shouldn't have anything to do with that. This virtual machine though, is Windows properly licensed? You know how Microsoft feels about one key being used it two places.

Share this post


Link to post
Share on other sites

I found a thread on this forum mentioning a registry fix posted elsewhere.

http://www.autoitscript.com/forum/index.ph...2.ocx&st=15

Here is the registry keys and they worked flawlessly for me!

Thanks whoever wrote it!

So I will make a registry-check everytime the application is run and fix it, if it is missing.

// The 16 bit and 32-bit OCX Professional license follows:

HKEY_CLASSES_ROOT\Licenses\DB4C0D00-400B-101B-A3C9-08002B2F49FB = mgkgtgnnmnmninigthkgogggvmkhinjggnvm

// The 32 bit OCX Professional license follows:

HKEY_CLASSES_ROOT\Licenses\7BC20EDC-4A42-101B-A3C9-08002B2F49FB = gifblihbhiiihbciocfbkifbqcfcdiebbiqh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0