Sign in to follow this  
Followers 0
TheMailman

_MemoryRead on dif. user application

4 posts in this topic

Ok 2nd help request in short interval, please bear with me.

Memory reading related issues using NomadMemory.au3, searched the forums but couldnt come up with sollution to this one.

Reading memory of another application that is open by another user account on the local pc. Everything returns 0, tried some silly workarounds but they broke my scripts totally. While searching i came across this nifty program called "PermEdit" but it didnt help jack, also found this : " SetPrivilege("SetDebugPrivilege", 1) " (or SeDebugPrivilige, dunno if its a typo, tried em both, no luck)

anyone got any ideas at all how would it be possible to read memory from a process that is open by another user on the local pc?

Share this post


Link to post
Share on other sites



Windows probably doesn't allow you to access another users data unless you have higher permissions or have their authentication. You may try running as the other user. If you are just trying to steal information though, there are probably better ways to do it.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

The program i am trying to steal information from is running many times on this local machine, but only one instance of such application can be run per user, so i have to run those clients on many different user accounts, but thanks for the great idea!

so lower those other accounts to limited rights, and see what happens. gotta check it out once i wake up!

ill update this once i get the results... and thanks again for the great idea

quickie edit : cant switch to other user accounts to retrieve the data, as it would take ages to go through 2-30 accounts :)

Edited by TheMailman

Share this post


Link to post
Share on other sites

ok allrighty, lowering the target exe's owner account to "limited" user still limits the admin account from reading that target programs memory in autoit3.

Which really bothers me is that when i run the client.exe on the activated account (admin) and then launch the autoit script on the same account (admin) which wants to read the memory, it works without a problem, however if i launch the client.exe as user LoL and then launch the autoit script as user LoL, it fails to read the memory.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0