Sign in to follow this  
Followers 0
GEOSoft

GUICtrlSetHelp

7 posts in this topic

I have the file name declared as a variable and a MSGBox shows the correct path.

It works fine when I call it from my help menu, its just F! that isn't working.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites



GUICtrlSetHelp? I don't know such a command...

<{POST_SNAPBACK}>

Sorry about that, I wish there was because then we might be able to have context sensitive help. :)

The line that does not work with F1 is

GUISetHelp ($HLP)

MsgBox(0,'TEST',$HLP) properly returns 'hh.exe 'and yhe full path and filename. Like I said $HLP works fine from the Help menu but not from F1.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Hmmm...I have no problem here.

What happens when you use this sample code?

GUICreate("time test")
$help = ("hh.exe C:\Anwendungen\AutoIt3\Autoit.chm"); try something similar
GUICtrlCreateDate("",10,10,100,20,0x09)
GUISetHelp($help)
GUISetState()

While 1
    $msg = GUIGetMsg()
    If $msg = -3 Then ExitLoop
WEnd

Exit

So long Holger...

Edited by Holger

Share this post


Link to post
Share on other sites

Hmmm...I have no problem here.

What happens when you use this sample code?

The Code I'm using is

$HLP = 'hh.exe '&@ScriptDir & '\B_GUI.chm'
GUICreate('My GUI',$GW,$GH)
GUISetHelp($HLP)
GUISetState()
While 1
    $msg = GUIGetMsg()
    If $msg = -3 Then Exit
WEnd

MsgBox(0,'TEST',$HPL) returns

hh.exe C:\Projects\G_Build\AutoIt\B_GUI.chm

which is correct.

Like I said it works fine from the help menu.


George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

And what happens with the sample code??? when you press F1 ???

GUICreate("time test")
$help = ("hh.exe C:\Anwendungen\AutoIt3\Autoit.chm")

$helpmenu = GUICtrlCreateMenu("?")
$helpitem = GUICtrlCreateMenuItem("Help",$helpmenu)

GUISetHelp($help)
GUISetState()

While 1
    $msg = GUIGetMsg()
    If $msg = -3 Then ExitLoop
    If $msg = $helpitem Then Run($help)
WEnd

Exit

So long...

Edited by Holger

Share this post


Link to post
Share on other sites

I've been recently trying to use GuiSetHelp with mixed success - sometimes (in a single application) it worked and sometimes it didn't. I've used essentially the code that Holger included below

$HLP = 'hh.exe ' & @ScriptDir & '\ADHelp.chm'
GUICreate('My GUI',$GW,$GH)
GUISetHelp($HLP)
GUISetState()
..
etc.

What I have just found is that whether it works depends on whether I've first pulled up Help from another application. For example, I can launch my app, press "F1" and get nothing. If I click on the Windows desktop and press "F1" to bring up the Windows "Help and Support Center", then select my (already running) app and press "F1", my help comes up. Same happens if I bring up AutoIt help from SciTe first -"F1" will work within my app. My help will continue to work once I've gotten it to work the first time but once I close my app, "F1" will not work when I relaunch it unless I first open Help from another app again. :)

Any thoughts?

Thanks

Sean

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0