Sign in to follow this  
Followers 0
Gif

IE question

12 posts in this topic

Hi all,

what i want is to embed a specific part of a site in a gui, like x,y pixels from left/top and a specific width/height. I cant work with changing source because things are executed on website.

Is that possible?

Thanks in advance

Share this post


Link to post
Share on other sites

no, a real site.

Share this post


Link to post
Share on other sites

no, a real site.

I meant what you wanted to get from the site. A screen shot of part of it, or do you imagine you can extract one form or frame and properly render it without the rest of the page, or... something else?

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Look into _IECreateEmbedded

I got the impression he had that, but wanted to only embed PART of the web page, which leads to the confusion on my part about exactly what is to be done.

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

i know it is a messy explaination but believe me it's hard to explain better..

All i want is to embed a part from a site. The user has no scroll bar and no way to see all part of the site....

like this example:

HERE

there will be a gui with a specific part of a site... i cant change the source cause everything is executed on server.

Is it possible?

Share this post


Link to post
Share on other sites

i know it is a messy explaination but believe me it's hard to explain better..

All i want is to embed a part from a site. The user has no scroll bar and no way to see all part of the site....

like this example:

HERE

there will be a gui with a specific part of a site... i cant change the source cause everything is executed on server.

Is it possible?

That looks like one column out of a table. You can use the _IE* tools to get the HTML of the table itself. It might work to create a blank embeded IE instance and write the HTML to the body of it.

Another option is to get just the values with _IETableWriteToArray() and create your own GUI presentation or HTML from scratch to present them.

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

That looks like one column out of a table. You can use the _IE* tools to get the HTML of the table itself. It might work to create a blank embeded IE instance and write the HTML to the body of it.

Another option is to get just the values with _IETableWriteToArray() and create your own GUI presentation or HTML from scratch to present them.

:)

  • There are no Tables
  • The object that i want is in javascript
  • what i presented to you is not real, just edited in MSpaint
  • I know _IE... funtions pretty well
well looks like what i want is not so possible ;)

Share this post


Link to post
Share on other sites

well looks like what i want is not so possible :)

Correct. If you cannot explain yourself well enough for others to understand, getting an answer is not possible.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Correct. If you cannot explain yourself well enough for others to understand, getting an answer is not possible.

Dale

sorry dale but i dont speak english proper enough to correctly explain what i need...

i am almost definatly sure it's not possible so i will take the hard way...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0