Sign in to follow this  
Followers 0
Fabry

Probaly bug: guictlsetpos (I think)

5 posts in this topic

I am projecting a simple battle tanks, but I encourred in a big trouble, if I shoot {SPACE} and move around after few minutes Edits, labels and listviews move in the grid.

Before:

Posted Image

After:

Posted Image

For the server you click 'Carica mappa' And open the mp_default.wld.

mp_default.wld:

CODE
[mappa]

grandezza=35x20

spawnA=4-4

spawnB=30-15

bandieraA=8-11

bandieraB=26-7

occupati=67

occupato1=2-8

occupato2=3-8

occupato3=4-8

occupato4=5-8

occupato5=6-8

occupato6=7-8

occupato7=8-8

occupato8=8-7

occupato9=8-6

occupato10=8-5

occupato11=8-4

occupato12=8-3

occupato13=8-2

occupato14=3-13

occupato15=3-14

occupato16=3-15

occupato17=3-16

occupato18=4-16

occupato19=5-16

occupato20=6-16

occupato21=7-16

occupato22=8-16

occupato23=9-16

occupato24=10-16

occupato25=15-0

occupato26=15-1

occupato27=15-2

occupato28=15-3

occupato29=18-4

occupato30=18-5

occupato31=18-6

occupato32=18-7

occupato33=18-8

occupato34=17-8

occupato35=16-8

occupato36=16-9

occupato37=16-10

occupato38=16-11

occupato39=16-12

occupato40=16-13

occupato41=18-16

occupato42=18-17

occupato43=18-18

occupato44=18-19

occupato45=25-3

occupato46=26-3

occupato47=27-3

occupato48=28-3

occupato49=29-3

occupato50=30-3

occupato51=31-3

occupato52=31-4

occupato53=31-5

occupato54=31-6

occupato55=32-11

occupato56=31-11

occupato57=30-11

occupato58=29-11

occupato59=28-11

occupato60=27-11

occupato61=26-11

occupato62=26-12

occupato63=26-13

occupato64=26-14

occupato65=26-15

occupato66=26-16

occupato67=26-17

And the source: Server:

[autoit]#Region ;**** Directives created by AutoIt3Wrapper_GUI ****

#AutoIt3Wrapper_Version=beta

#EndRegion ;**** Directives created by AutoIt3Wrapper_GUI ****

#cs ----------------------------------------------------------------------------

AutoIt Version: 3.2.8.1

Author: myName

Script Function:

Template AutoIt script.

#ce ----------------------------------------------------------------------------

; Script Start - Add your code below here

$versione = FileGetVersion(@AutoItExe)

#region parametri socket

$My_ips = StringSplit(@IPAddress1, '.')

$Broadcast = $My_ips[1] & '.' & $My_ips[2] & '.' & $My_ips[3] & '.255'

Dim $Tcpsocket = ''

UDPStartup()

$socket = UDPBind(@IPAddress1, 65500)

If @error <> 0 Then

MsgBox(16, 'Errore socket', 'Non


A lan chat (Multilanguage)LanMuleFile transferTank gameTank 2 an online game[center]L'esperienza è il nome che tutti danno ai propri errori.Experience is the name everyone gives to their mistakes.Oscar Wilde[/center]

Share this post


Link to post
Share on other sites



I find a solution, but I encourred in other problem 4>=20 is true (?!?). AutoIt is gone crazy.

You probably are doing a string compare in stead of a numeric compare ....

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0