Sign in to follow this  
Followers 0
cmattb

executes stuff twice

6 posts in this topic

So im having a problem with my scripts, and cannot figure it out. For the longest time, everything has worked great, but since yesterday, all of the butttons on my GUI execute twice. It seems like if I dont color the button, everything works great, but if I set the color of the button, it does everything twice. Anyone have any ideas? Im running the newest version of Autoit. Sample script below

#include <guiconstants.au3>
Opt("GUIOnEventMode", 1)
$gui = GuiCreate("title", 200, 200)
Global $devicemanager = GUICtrlCreatebutton("Device Manager", 0, 20, 110, 20)
;GuiCtrlSetBkColor($devicemanager, 0x99CCFF)
GUICtrlSetOnEvent($devicemanager, "dmanager")
GUISetState ()          
While 1
    sleep(100)
WEnd
Func dmanager()
Run(@ComSpec & " /c " & '%SystemRoot%\System32\compmgmt.msc', "", @SW_HIDE)
EndFunc

Thanks for the help guys

Share this post


Link to post
Share on other sites



I'm pretty sure there is a known bug with double execution of colored buttons. I think its fixed in the beta.

Share this post


Link to post
Share on other sites

Running with latest beta version only gives 1 Computer Management and colored button


Kerros===============================================================How to learn scripting: Figure out enough to be dangerous, then ask for assistance.

Share this post


Link to post
Share on other sites

So im having a problem with my scripts, and cannot figure it out. For the longest time, everything has worked great, but since yesterday, all of the butttons on my GUI execute twice. It seems like if I dont color the button, everything works great, but if I set the color of the button, it does everything twice. Anyone have any ideas? Im running the newest version of Autoit.

Known bug. The fix is currently in the Beta at 3.2.9.2 and later, so if you are using the latest production it's not there yet.

<_<


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Ah, well then, i guess that answeres that. Thanks for the quick replies all. Guess no fancy colored buttons for now.

Share this post


Link to post
Share on other sites

Ah, well then, i guess that answeres that. Thanks for the quick replies all. Guess no fancy colored buttons for now.

I feel your pain. The same thing happened to me in another topic I was working on here:

http://www.autoitscript.com/forum/index.php?showtopic=56076

The first script I wrote has colored buttons but they never worked right, the later ones just use a different font instead.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0