Sign in to follow this  
Followers 0
sness

Premature Message?

7 posts in this topic

Hi Everyone.

I'm proud to announce that I have created my first functioning scripts today (complete w/variables) with AutoIt (ex-AutoTester user here). I put a msgbox(0,"Finished","Finished",2000) at the end of my script so I could know for sure it is done executing. Funny thing is that the message pops up BEFORE the commands are all executed into the terminal emulator program I'm testing. Why is this?

Thanks everyone for your feedback! <_<

Sue

Share this post


Link to post
Share on other sites



we are not mind readers...

we can only help if you show us code

8)


NEWHeader1.png

Share this post


Link to post
Share on other sites

Well, can't really solve your problem without your code... <_<

Share this post


Link to post
Share on other sites

OK, Here it is.

The script runs without error. Just curious why the last line of code would execute before some of the lines before it (if that's what is happening). In other words, the message pops up and commands are still getting entered onto the test applicaton behind it. This is my first time sending code up to this bulletin board. I attached it.

Sue

Admit01.au3

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

They might be being sent to fast... Look at Opt("SendKeyDelay"... and see if adjusting the speed a bit of the sent keys actually gets everything sent.

Might also (if you can) look at ControlSend() instead of Send().

Edited by SmOke_N

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

They might be being sent to fast... Look at Opt("SendKeyDelay"... and see if adjusting the speed a bit of the sent keys actually gets everything sent.

Might also (if you can) look at ControlSend() instead of Send().

OK, I will try that. Thanks!

Sue

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Hello sness,

I want to assume that the patient data in your script is dummy data and not actual data that can be used to nefarius ends. Would my assumption be correct?

Zach...

Edit: this community appears to be well policed as far as unscrupulous activity is concerned. But still...

Edited by zfisherdrums

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0