Sign in to follow this  
Followers 0
tele

Sitcky Mouse Click?!

3 posts in this topic

Dear All,

I am writing a script to start a process on clicking of the left mouse button. It looks like this

If _IsPressed("01") Then

Do the things that I want

Else

Something else

EndIf

It should be straightforward. However, I found that the If statement is always true once the Left Mouse button was clicked. It just like that the button never come back up! Of cuase, I have checked my mouse buttons and they are working fine.

I am not sure if I have done something silly. :P

much appreciated if someone could kindly show me the light to a work-around of this "problem" please.

Terry

Share this post


Link to post
Share on other sites

If you post the exact code that creates this error we may be able to help. Because running that code with tooltips shows and functions exactly as expected..

Share this post


Link to post
Share on other sites

If you post the exact code that creates this error we may be able to help. Because running that code with tooltips shows and functions exactly as expected..

Paulie,

Thanks! I have kind of solved the problem with the following:

If _IsPressed("01") Then

Do

Until (Not _IsPressed("01))

.....

Thanks again

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0