Jump to content
Sign in to follow this  
methodclass

@ipaddress1 flawed

Recommended Posts

methodclass

ok folks, before i start getting flamed, the machine HAS an ip.

i'm using @ipaddress1 to obtain the primary ip address of the machine script is being run from. it works fine on

my windows xp workstation and a few windows nt4/2000 machines, but i get the odd nt4/2000 workstation that

displays;

'Line -1:

Error: Error in expression' and the program halts

ive confirmed it is @ipaddress1 causing this error, as i made a copy of the script and replaced any reference to

@ipaddress1 with a string (containing an ip address) and the script runs fine.

im not going to post source as it seems you only need to utilise the variable for the error message to occur.

i'm running AutoIT 3.2.8.1 and running the script as a .exe from the other machines

Windows XP with SP2 seems to work fine

I've tried this on two Windows 2000 machines each with SP4, one failed, one worked

Also tried this on two Windows NT4 servers, again both with SP6, one failed, one worked

Script is being run as administrator (which shouldnt matter anyway)

Share this post


Link to post
Share on other sites
Valik

No script means you don't want the problem solved. Besides, it's not a bug until proven and no script means no proof. Post in support, that's where your problem will be solved, anyway.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×