Jump to content
Sign in to follow this  
GWmellon

oddball error in _ArrayDisplay

Recommended Posts

GWmellon

;Shows an oddball error in _ArrayDisplay

#include <Array.au3>
Dim $avArray[3]

$avArray[0] = "| Relocate|45| St Paul Hbr Ent Lt Fl 6s 38ft 7M RACON (-.) LNM 32/07, 17th Dist| 57.73871889| -152.430096"
$avArray[1] = "| Revise|29| St Paul Hbr Ent Lt Fl 6s 38ft 7M RACON (-.) LNM 32/07, 17th Dist| 57.73871889| -152.430096"
$avArray[2] = "| Revise|29| Subm buoy Subm buoy (cov 90 fms) WNM 08/07, NIMA| 57.72233333| -152.293666"
_ArrayDisplay( $avArray, "sorted" )

When the listview for the _ArrayDisplay appears the pipes ("|") become tildes ("~")

If I view the array any other way the pipes remain.

Share this post


Link to post
Share on other sites
randallc

;Shows an oddball error in _ArrayDisplay

#include <Array.au3>
Dim $avArray[3]

$avArray[0] = "| Relocate|45| St Paul Hbr Ent Lt Fl 6s 38ft 7M RACON (-.) LNM 32/07, 17th Dist| 57.73871889| -152.430096"
$avArray[1] = "| Revise|29| St Paul Hbr Ent Lt Fl 6s 38ft 7M RACON (-.) LNM 32/07, 17th Dist| 57.73871889| -152.430096"
$avArray[2] = "| Revise|29| Subm buoy Subm buoy (cov 90 fms) WNM 08/07, NIMA| 57.72233333| -152.293666"
_ArrayDisplay( $avArray, "sorted" )

When the listview for the _ArrayDisplay appears the pipes ("|") become tildes ("~")

If I view the array any other way the pipes remain.

Hi,

You need to use the option to change the ListView data separator in "_arrayDisplay"; that is why that option is there;

_ArrayDisplay( $avArray, "sorted",1,0,"~" )
Best, randall

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×