Sign in to follow this  
Followers 0
kjcdude

filegetversion error

3 posts in this topic

#1 ·  Posted (edited)

I'm working on a script to verify that the version of files are correct then log them into a file, later to be used to execute scripts to fix the problem.

But i'm running into a problem.

For wow 2.3.0.7561 the file version isn't working correctly. I tested the script on a few computers that have incorrect versions and for wow, it still reported 1, that the version was correct even though it's not.

But it reported correctly, or falsley reported correctly on computers that have the correct version.

The weird thing is when i msgbox'd the 2 wow version variables they reported correctly, meaning old versions.

The only other one i've tested is cod4, which reported correctly when the file did not exist, thus no version.

Thanks

------------

fixed, just rewrote it to act in the positive instead of negative

Edited by kjcdude

Share this post


Link to post
Share on other sites



I am confused..

But... compare the FileGetVersion() information with the version info shown when you do right-mouse-click/ properties and see what the difference is.


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0