Sign in to follow this  
Followers 0
Klexen

Help! Norton is deleting my program.

10 posts in this topic

I guess a norton update is now thinking my program is a virus and is deleting it. Unfortunately I have no control over norton as my program is being used by a lot of collegues of mine at work. If there is anything I can do to have my program not be detected as a virus please let me know.

Share this post


Link to post
Share on other sites



Go to your system administrator and tell him to turn it off for a while.

Poor answer. I you came to me with that request, I would be HIGHLY suspicious!

Go to your system administrator (who already knows about false positives, surely) and carefully detail you script and what's happening. Show the source, show some info from this site, and make sure you give proper/polite/professional notification back to Symantec/McAffee/etc. about the false positive.

If you are using a reputable AV product, the updated definitions should be out in days. In the mean time, the admin will only have to exclude the file(s) being hit temporarily... NOT disable the AV software.

:P


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

or just ask him to stop .au3 files being deleted.

An .au3 file should never be detected as malicious. It's just a text file. Only compiled scripts (.exe) can be detected as malicious, as far as I know. Generally because of false positive hits on the UPX packer binary or the AutoIt interpreter binary.

:P


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

> I guess a norton update is now thinking my program is a virus and is deleting it.

Same problem with one of my tools.

> Unfortunately I have no control over norton

System IT in my office don't want to stop it. I agree with that.

> as my program is being used by a lot of collegues of mine at work.

Collegues in my office aren't able to use my tool anymore.

I tried to compile my tool but the file

C:\Program Files\AutoIt3\Aut2Exe\AutoItSC.bin

has been deleted by Norton Antivirus V10.1.6.6010

Scan engine: 71.3.0.25 Virus Definitions File 26.11.2007 rev.21

How many time should we wait before having a virus definition without this false positive ?

Yves

Edited by Yves1Fix

Share this post


Link to post
Share on other sites

How many time should we wait before having a virus definition without this false positive ?

Yves

- Have you complained to Symantec and submitted the false positive ?

- Have you tried the latest rapid release Symantec supplies (depending on what version of AV you are running ?

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

I had the same problem this morning. The latest round of Symantec updates falsely detected virus on all my compiled 3.2.8.1 scripts. It thought they contained the following virus:

W32.Blastclan

I was able to install the latest autoit 3.2.10 today and compile the same scripts and they were not detected as viruses. In addition, I found the compiling those scripts with an earlier versin of autoit 3.2.4.9 also worked fine.

Hope this helps you out.

David

Share this post


Link to post
Share on other sites

I had the same problem this morning. The latest round of Symantec updates falsely detected virus on all my compiled 3.2.8.1 scripts. It thought they contained the following virus:

W32.Blastclan

I was able to install the latest autoit 3.2.10 today and compile the same scripts and they were not detected as viruses. In addition, I found the compiling those scripts with an earlier versin of autoit 3.2.4.9 also worked fine.

Hope this helps you out.

David

http://www.autoitscript.com/forum/index.ph...mp;#entry439376

http://www.autoitscript.com/forum/index.php?showtopic=34658


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0