Sign in to follow this  
Followers 0
sshrum

Refreshing picture controls

5 posts in this topic




Opps. Sorry bout that.

Real simple: I have a picture control on a GUI and using GUICtrlSetImage() to change it but the image displayed is not switching to the new image (the prior image is still displayed).

I've run into issues when the image is not supported but I can load the image into another picture control when I create the picture control.


Sean Shrum :: http://www.shrum.net

All my published AU3-based apps and utilities

'Make it idiot-proof, and someone will make a better idiot'

 

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Without code snippet it's hard to help.

But I think that you try to use unsupported image type in GUICtrlSetImage()

or you have wrong (absolute/relative) path to image.

Read AutoIt HelpFile carefully.

Edited by Zedna

Share this post


Link to post
Share on other sites

Thanks for the advice...but please note that I indicated that I can load the image into a newly created picture control which implies that the path is correct and the image is supported.

This is why I'm perplexed...the control isn't refreshing to the new image after I run GUICtrlSetImage()


Sean Shrum :: http://www.shrum.net

All my published AU3-based apps and utilities

'Make it idiot-proof, and someone will make a better idiot'

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0