Jump to content
Sign in to follow this  
Jos

New Scite4AutoIt3 installer

Recommended Posts

Tested, worked great, thanks  :lmao:

Will this be include in your next release ?

<{POST_SNAPBACK}>

Will be part of the next version ....

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Uploaded a new version of SciTe4AutoIt3.exe which contains the production release definitions for v3.1.0 released Feb 7, 2005 and also contains below updates.

==> Visit the SciTe4AutoIt3 Download page for the latest versions

==> Check the online documentation for an overview of all extra's you get with the SciTE4AutoIt3 installer.

Enjoy,

02/08/2005
*** Added Peppe's CodeWizard.exe to SciTE and linked it to Alt+M
*** Updated Production definitions to V 3.1.0.
*** Added /S switch to UpdateDefs for silent install.
*** Fixed SciTEConfig issue retrieving the currect setting.

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Hi JdeB,

Is it right that in the Menu of Scite i see xxxBox Wizard (Alt-M)

instead of MsgBox ......

Andre


What about Windows without using AutoIt ?It would be the same as driving a car without an steering Wheel!

Share this post


Link to post
Share on other sites

Hi JdeB,

Is it right that in the Menu of Scite i see xxxBox Wizard  (Alt-M)

instead of MsgBox ......

Andre

<{POST_SNAPBACK}>

Yeap ... its the new codewizard which is MsgBox and InputBox so i changed it from MsgBox to "xxBox Wizard"... :lmao:

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Can we have a small extension to debug command?

usely I put trace (debug to console) where I think I need them. put when i am in big mess (debug add trace line).

the problem I want to solve is remove only the trace lines not the (debug to console)

Today (debug remove all lines) is available, I suggest we have a (debug remove trace lines).

Thanks for your support to this more than helpfull autoit editor :lmao:

Share this post


Link to post
Share on other sites

Don't know whether to post this here, or in the updater thread, but is there any chance of you / Jon / Saunders putting something together for checking for SciTe updates? Maybe integrated into the AutoIt updater in some way?

Share this post


Link to post
Share on other sites

Wonderful! Thank you so much for creating this great tool :lmao:


[quote name='d2hacker88' date='Jan 6 2005, 05:10 PM']Can someone please help me out with autoit like gimme a link on how to use it cause i have no experience with computer languages and i'd like to make a program with autoit in order to empress my computer teacher.[right][snapback]52215[/snapback][/right][/quote]

Share this post


Link to post
Share on other sites

au3.api file for both defs contains this at the end:

_viClose ($h_session) Closes a VISA connection to an Instrument/Device (Requires: #include <Visa.au3>)

_viExecCommand ($h_session, $s_command, $i_timeout_ms = -1) Send a Command/Query to an Instrument/Device through the VISA interface (GPIB / TCP) (Requires: #include <Visa.au3>)

_viFindGpib (ByRef $a_descriptor_list, ByRef $a_idn_list, $f_show_search_results = 0) Send a Command/Query to an Instrument/Device through the VISA interface (GPIB / TCP) (Requires: #include <Visa.au3>)

_viGpibBusReset () GPIB BUS "reset":

Use this function when the GPIB BUS gets stuck for some reason.

You might be lucky and resolve the problem by calling this function (Requires: #include <Visa.au3>)

_viGTL ($h_session) Go To Local mode:

Instruments that accept this command will exit the "Remote Control mode" and go to "Local mode".

If the instrument is already in "Local mode" this is simply ignored.

Normally, if an instrument does not support this command it will simply stay in the "Remote Control mode" (Requires: #include <Visa.au3>)

_viOpen ($s_visa_address, $s_visa_secondary_address = 0) Opens a VISA connection to an Instrument/Device (Requires: #include <Visa.au3>)

_viSetAttribute ($h_session, $i_attribute, $i_value) Set any VISA attribute

This function, which is called by _viSetTimeout, can ALSO be used to set the

other VISA specific attributes.

Read the VISA documentation for more information and a list of VISA attributes

and their corresponding values. (Requires: #include <Visa.au3>)

_viSetTimeout ($h_session, $i_timeout_ms) Sets the VISA timeout in MILISECONDS (Requires: #include <Visa.au3>)

and it's screwing up intellisense.

@JdeB, could you have a look please?

Thanks.

Share this post


Link to post
Share on other sites

au3.api file for both defs contains this at the end:

and it's screwing up intellisense.

@JdeB, could you have a look please?

Thanks.

<{POST_SNAPBACK}>

I will check the doc files for these functions... they propably still contains a few @CRLF's ...

Here's a fixed version of au3.api ...

Download and copy into : C:\program files\Autoit3\Scite\api

thanks


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Installer is updated.

If you want to just patch the definition files with the correct version then download SciTe4Au3Upd.exe and run it.


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Can we have a small extension to debug command?

usely I put trace (debug to console) where I think I need them. put when i am in big mess (debug add trace line).

the problem I want to solve is remove only the trace lines not the (debug to console)

Today (debug remove all lines) is available, I suggest we have a (debug remove trace lines).

Thanks for your support to this more than helpfull autoit editor :lmao:

<{POST_SNAPBACK}>

JP,

Here are some test files to see if thats what you want.

It has the following changes:

- Added option to tools menu called: Debug: Remove Trace lines

- Debug: Remove ALL lines still removes everything.

- added LUA function Remove_Trace()

- changed comment at the end of trace lines to identify them

Attached Scite.zip contains the modified au3.properties and autoit3.lua files..

o:)


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

JP,

Here are some test files to see if thats what you want.

It has the following changes:

- Added option to tools menu called: Debug: Remove Trace lines

- Debug: Remove ALL lines still removes everything.

- added LUA function Remove_Trace()

- changed comment at the end of trace lines to identify them

Attached Scite.zip contains the modified au3.properties and autoit3.lua files..

o:)

<{POST_SNAPBACK}>

Just What I want. Thanks a lot :lmao:

Now I just miss what Scite developper should a way to have to windows at the same time displaying 2 differents files.

Just a remarks with a lot of files open the texpad approach is better than the Scite tab to switch from one file to another.

Share this post


Link to post
Share on other sites

JP,

Here are some test files to see if thats what you want.

It has the following changes:

- Added option to tools menu called: Debug: Remove Trace lines

- Debug: Remove ALL lines still removes everything.

- added LUA function Remove_Trace()

- changed comment at the end of trace lines to identify them

Attached Scite.zip contains the modified au3.properties and autoit3.lua files..

o:)

<{POST_SNAPBACK}>

more info it look like the scite.zip break the Go(F5) can you have a look thanks :lmao:

I found the problem my autoit is installed as my system on F: not C:

Edited by jpm

Share this post


Link to post
Share on other sites

Just What I want. Thanks a lot :lmao:

Now I just miss what Scite developper should a way to have to windows at the same time displaying 2 differents files.

Just a remarks with a lot of files open the texpad approach is better than the Scite tab to switch from one file to another.

<{POST_SNAPBACK}>

yea i know... not much i can do about it since i am not planning to maintain a different SciTE build but intent to stick to the standard build make by Neil.

I will add these LUA changes to the next version of the installer. o:)


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

JdeB,

Thanks for all the hard work you and the team have done with the scite for AutoIT. I do have a question though with the sciteconfig portion. When I wanted to change the color of a keyword group to black text, It let me select the black color, but it didn't change it to black. I had to edit the properties file manually to change the color to black.

I had thought that it was the installer version I had so I downloaded the most recent from the download area, but it still would not allow me to change the color to black. I noticed that you had provided us the au3 source for this wonderful program and I think I found out why, but I wasn't sure:

(Line 229)

For $x = 1 To 14
.....
If $RC = $H_Syn_fColor[$x] Then
    $tempcolor = SelectColor($Syn_Label[$x], $Syn_fColor[$x])   
    If $tempcolor <> 0 Then $Syn_fColor[$x] = $tempcolor
    GUICtrlSetColor($H_Syn_Label[$x], $Syn_fColor[$x])
EndIf

If $tempcolor <> 0 Then $Syn_fColor[$x] = $tempcolor

If the color the user selects is black which has a value of RGB(0,0,0) or 0x000000

which is equivalent to 0 so the code does not set the color.

Was this code in place to catch a cancel event from the select color dialog? If there isn't a workaround, that's fine because I updated the color manually and I know to select a value similar to black like RGB(1,1,1) or 0x111111 for any other ones I wish to change. I was just curious if this was the problem or have I just lost my mind? :lmao:


The world is flat - Class of 1492

Share this post


Link to post
Share on other sites

If $tempcolor <> 0 Then $Syn_fColor[$x] = $tempcolor

If the color the user selects is black which has a value of RGB(0,0,0) or 0x000000

which is equivalent to 0 so the code does not set the color.

Was this code in place to catch a cancel event from the select color dialog?  If there isn't a workaround, that's fine because I updated the color manually and I know to select a value similar to black like RGB(1,1,1) or 0x111111 for any other ones I wish to change.  I was just curious if this was the problem or have I just lost my mind? :lmao:

<{POST_SNAPBACK}>

Yea you are correct... the config program i wrote to update the SciteUser.properties file doesn't take into account that you want to use Black for any of the 13 options......

Are your seriously changing the default color to something else and then changing the color for Keywords to black ????

EDIT: on second thought having looked a the script we can just change:

line 234 to: $Syn_fColor[$x] = $tempcolor

line 239 to: $Syn_bColor[$x] = $tempcolor

Edited by JdeB

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Yea you are correct... the config program i wrote to update the SciteUser.properties file doesn't take into account that you want to use Black for any of the 13 options......  

Are your seriously changing the default color to something else and then changing the color for Keywords to black ????

EDIT: on second thought having looked a the script we can just change:

line 234 to: $Syn_fColor[$x] = $tempcolor

line 239 to: $Syn_bColor[$x] = $tempcolor

<{POST_SNAPBACK}>

I don't know why I wrote Keywords. No actually I was dabbling with the text colors for the Numbers. When I decided to change it back to black which is how I like to see numbers in the scite editor. That's when I realized I couldn't change it to black.

I was under the belief that the if a user cancel a color change then the

window would return 0 which is why I thought you have that logic in there to prevent the program from changing the color to black if they click cancel. It appears that the code change you mentioned would work. I don't think you would need to change it unless you wanted to since it doesn't update until the user clicks the update button.

Thanks for this tool, and the hard work you and the team put into this. It makes it easier to test and run AU3 code from the Scite editor. I was using Textpad and Notepad before this.

Edited by frogonalog

The world is flat - Class of 1492

Share this post


Link to post
Share on other sites

Yes that change would work.  I don't think you would need to change it unless you wanted to.  It might confuse someone if they clicked the cancel button and the return result was 0 which changed their color to black. 

<{POST_SNAPBACK}>

Think that with this change the cancel will work now... did you try it ?

In the beginning Selectcolor returned 0 and thats why the test is in the script, but now i think the SelectColor program returns the original color in the case Cancel was clicked..

Enjoy :lmao:

Edited by JdeB

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Think that with this change the cancel will work now...  did you try it ?

In the beginning Selectcolor returned 0 and thats why the test is in the script, but now i think the SelectColor program returns the original color in the case Cancel was clicked..

Enjoy    :lmao:

<{POST_SNAPBACK}>

It works like a charm. o:)

The world is flat - Class of 1492

Share this post


Link to post
Share on other sites

Uploaded a new version of SciTe4AutoIt3.exe which contains the definitions for v3.1.0.15j released March 15, 2005 and also contains below updates.

==> Visit the SciTe4AutoIt3 Download page for the latest versions

==> Check the online documentation for an overview of all extra's you get with the SciTE4AutoIt3 installer.

Enjoy,

03/19/2005
*** Updated Tidy v 1.28.4:
    fixed to handle spaces after continuation character.
    fixed extra spaces between double braces.
    Fixed Save of Config issue with combo boxes.
*** Added FuncList LUA script which lists all available Func's and allows you to jump to them. Alt+L
*** Updated Trace LUA script: When lines are selected it will only add trace lines to those lines.
*** Updated Abbreviations LUA script that now also the ToolTip is shown for the expanded function 
    and the indentation is set correctly for the inserted text.
*** Added LUA script which allows you to keep backups of your edited script.
*** Fixed #include-once in definition files (was #include_once)
*** Updated CodeWizard.exe v 1.2
*** Updated ScTEConfg v 1.0.3 to be able to handle other languages.
*** Added VoSs2o0o's AutoItMacroGenerator Alt+F7

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...