Sign in to follow this  
Followers 0
Pretend2Script

#AutoIt3Wrapper_PassPhrase - Am I missing something?

6 posts in this topic

I usually never have to post (which is evident from the non-existent number of post I have made) as I normally find everything I need by searching through everyone's brilliantly clear responses in the forums. That being said, I will apologize up front if I have missed this information in my searches.

After a lost HD (luckily all my scripts were backed up) I had to re-install all of my AutoIt installs (including SciTe, cvswrapper, and of course the latest version of AutoIt). After doing so, I noticed that the option in the GUI for Allow Decompile and Passphrase were gone. In addition the reference:

#AutoIt3Wrapper_PassPhrase=??????

was no longer recognized by the SciTe Editor. I've searched for information on the GUI Wrapper, the editor, and on #AutoIt3Wrapper_PassPhrase, but found nothing that answered this question (or I did and must not have understood it).

If anyone can point me toward an answer or another thread that I may have missed the answer in, it would be greatly appreciated...

Sincere thanks - Chris


The difference between Genius and Stupidity is that Genius has its limits....Einstein

Share this post


Link to post
Share on other sites



This isn't reconized in my Scite editor, but it still works fine.

Share this post


Link to post
Share on other sites

I usually never have to post (which is evident from the non-existent number of post I have made) as I normally find everything I need by searching through everyone's brilliantly clear responses in the forums. That being said, I will apologize up front if I have missed this information in my searches.

After a lost HD (luckily all my scripts were backed up) I had to re-install all of my AutoIt installs (including SciTe, cvswrapper, and of course the latest version of AutoIt). After doing so, I noticed that the option in the GUI for Allow Decompile and Passphrase were gone. In addition the reference:

#AutoIt3Wrapper_PassPhrase=??????

was no longer recognized by the SciTe Editor. I've searched for information on the GUI Wrapper, the editor, and on #AutoIt3Wrapper_PassPhrase, but found nothing that answered this question (or I did and must not have understood it).

If anyone can point me toward an answer or another thread that I may have missed the answer in, it would be greatly appreciated...

Sincere thanks - Chris

That's because the latest version of AutoIt 3.2.10.0 is not longer supportin decompile, therefore the passphrase is no longer needed.

Share this post


Link to post
Share on other sites

Sadly, after I posted I finally found the history file entry...

http://www.autoitscript.com/autoit3/scite/docs/history.htm

"9/9/2007

*** Updated AutoIt3Wrapper_Gui/AutoIt3Wrapper v1.9.3 (JdeB)

- Added: %autoitdir% support in Run_Before and Run_After directives

- Added: Skip the Source Directives update when no changes are made in AutoIt3Wrapper_GUI.

- Added: #AutoIt3Wrapper_Res_SaveSource which will add the ScriptSource to the Output program resource section AutoIt3:ScriptSource.

- Added: #AutoIt3Wrapper_Res_File_Add which will add the specified file to the Output program resource.

- Removed: support for #AutoIt3Wrapper_allow_decompile and #AutoIt3Wrapper_passphrase

- Fixed: Possible issue with the Fileversion AutoIncrement replacing it on the wrong line.

- Fixed: Bug running UPX in Win9x."

Anyone know the reasoning behind it? Not questioning the decision, just curious :) I always used that feature; is there anything new that comparable?


The difference between Genius and Stupidity is that Genius has its limits....Einstein

Share this post


Link to post
Share on other sites

Sadly, after I posted I finally found the history file entry...

http://www.autoitscript.com/autoit3/scite/docs/history.htm

"9/9/2007

*** Updated AutoIt3Wrapper_Gui/AutoIt3Wrapper v1.9.3 (JdeB)

- Added: %autoitdir% support in Run_Before and Run_After directives

- Added: Skip the Source Directives update when no changes are made in AutoIt3Wrapper_GUI.

- Added: #AutoIt3Wrapper_Res_SaveSource which will add the ScriptSource to the Output program resource section AutoIt3:ScriptSource.

- Added: #AutoIt3Wrapper_Res_File_Add which will add the specified file to the Output program resource.

- Removed: support for #AutoIt3Wrapper_allow_decompile and #AutoIt3Wrapper_passphrase

- Fixed: Possible issue with the Fileversion AutoIncrement replacing it on the wrong line.

- Fixed: Bug running UPX in Win9x."

Anyone know the reasoning behind it? Not questioning the decision, just curious :) I always used that feature; is there anything new that comparable?

Well as I mentioned, the reason I think would be there was a crack decompiler that can decompile regardless password/no password. Now Jon said he used another technology to compile, hopefully this will keep the source safe for a while.

Share this post


Link to post
Share on other sites

Well as I mentioned, the reason I think would be there was a crack decompiler that can decompile regardless password/no password. Now Jon said he used another technology to compile, hopefully this will keep the source safe for a while.

Apologies, I didn't catch that. Hadn't heard that there was a crack out ther for the decompile. I'm all about safety! Bravo Jon on the update and thanks so much for the info Generator!


The difference between Genius and Stupidity is that Genius has its limits....Einstein

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0