Jump to content
Sign in to follow this  
Vindicator209

Embedded IE freeze?

Recommended Posts

Well, I'm not sure why but it seems that using IE in my script causes it to freeze up and spike my CPU to 50.

I was wondering what is causing this and/or how to fix it?

Theres not prior action to the freeze, except _IENavigate, which I know is not likely to be the problem, but I'll show that bit anyway:

Case $Button1
            $templink = GUICtrlRead(GUICtrlRead($ListView1),2)
            $ID = StringSplit($templink,"|")
            _IENavigate($oIE,"http://www.gamerzplanet.net/forums/inferno.php?do=place&id="&$ID[2])

EDIT: well I forgot to say, the site I'm using this on involves a bunch of vbobjects and stuff

For example, a single line:

<div class="vbmenu_popup" id="worldmap_place_18_menu" style="display:none">
Edited by MethodZero

[center]"When you look at old, classic games like Snake, you often put it off because it's such a simple game, but it's only when you actually try and create your own unique game from scratch, do you finally appreciate those games."[/center][center]Don't ask for answers if you haven't TRIED yet![/center][center]Most answers can be answered in the help file! Use it![/center]

Share this post


Link to post
Share on other sites

Has noone had this problem before? I had thought it might've been a popular problem..


[center]"When you look at old, classic games like Snake, you often put it off because it's such a simple game, but it's only when you actually try and create your own unique game from scratch, do you finally appreciate those games."[/center][center]Don't ask for answers if you haven't TRIED yet![/center][center]Most answers can be answered in the help file! Use it![/center]

Share this post


Link to post
Share on other sites

Try using the SciTe debug node to better ascertain where you freeze (see my sig)

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Where exactly do I use that? Is there a command console?


[center]"When you look at old, classic games like Snake, you often put it off because it's such a simple game, but it's only when you actually try and create your own unique game from scratch, do you finally appreciate those games."[/center][center]Don't ask for answers if you haven't TRIED yet![/center][center]Most answers can be answered in the help file! Use it![/center]

Share this post


Link to post
Share on other sites

Put this #AutoIt3Wrapper_run_debug_mode=Y at the top of your script and run it from SciTe

Share this post


Link to post
Share on other sites

I can't do that, because the IE Object wont work if not compiled, i dunno why, I can give you the code if anyone is nice enough to do it for me...

EDIT: On second thought, I cant have anyone do it for me because it involves traveling to another page where you need a username /password, so blegh

HOWEVER, checking it anyway, I get this:

>Running:(3.2.10.0):C:\Program Files\AutoIt3\autoit3.exe "C:\Documents and Settings\Kyle\My Documents\RPG Inferno\RPG Inferno.au3"  
--> COM Error Encountered in RPG Inferno.au3
----> $IEComErrorScriptline = 237
----> $IEComErrorNumberHex = 8007007F
----> $IEComErrorNumber = -2147024769
----> $IEComErrorWinDescription = The specified procedure could not be found.
----> $IEComErrorDescription = 
----> $IEComErrorSource = 
----> $IEComErrorHelpFile = 
----> $IEComErrorHelpContext = 
----> $IEComErrorLastDllError = 127

--> IE.au3 V2.3-1 Error from function _IECreateEmbedded (WebBrowser Object Creation Failed)
--> COM Error Encountered in RPG Inferno.au3
----> $IEComErrorScriptline = 26
----> $IEComErrorNumberHex = FFFFFFFF
----> $IEComErrorNumber = -1
----> $IEComErrorWinDescription = The specified module could not be found.
----> $IEComErrorDescription = 
----> $IEComErrorSource = 
----> $IEComErrorHelpFile = 
----> $IEComErrorHelpContext = 
----> $IEComErrorLastDllError = 126

--> IE.au3 V2.3-1 Error from function _IENavigate, $_IEStatus_InvalidDataType
Edited by MethodZero

[center]"When you look at old, classic games like Snake, you often put it off because it's such a simple game, but it's only when you actually try and create your own unique game from scratch, do you finally appreciate those games."[/center][center]Don't ask for answers if you haven't TRIED yet![/center][center]Most answers can be answered in the help file! Use it![/center]

Share this post


Link to post
Share on other sites

Is that all ths output to the SciTe console? If so, you are not using debug mode properly yet.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...