Sign in to follow this  
Followers 0
Nova

Reg Refresh

5 posts in this topic

Ive been messing with registry vaules for the past while which invoke policies in windows xp.

I am trying to wright a script for admin usage to quickly add certain policies to an active users account.

I know that the below registry value removes the current users premission to use the run bar !

Regwrite("HKEY_CURRENT_USER\Software\Microsoft\windows\currentversion\Policies\Explorer","NoRun","REG_DWORD","0")

Problem is that this registry value dosent take effect until the user logs off and then logs back on !

I was woundering if there is a way to refresh these registry values without having to log off and back on.

The only other method I can think of is killing explorer.exe and then running it again but I dont really want to have to do this.

O yea and another thing why dose the folder My documents open when u start explorer.exe with the run command and what parameters must I add to stop this from happening ?

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

( a ) There is no other way besides explorer kill because of a windows limitation.

( b ) explorer "Foldername to open" (explorer C:\)

Edited by this-is-me

Who else would I be?

Share this post


Link to post
Share on other sites

Tnx this-is-me

explorer "Foldername to open" (explorer C:\)

What if I dont want any folder to open but just to start explorer.exe so as the desktop and all GUI settings that explorer.exe controls reapear.

Run("explorer.exe") ;Starts explorer.exe and opens My Documents

I dont understand why my documents is opened and how I stop it from opening !

and cheers Larry but sadly EnvUpdate() dosent have any effect in this situation :)

Share this post


Link to post
Share on other sites

Also is there any way of disabling the start button and menu so that the current user would only have axcess to the shortcuts pre placed on the desktop ?

Share this post


Link to post
Share on other sites

( 1 ) Explorer will automatically start with my documents when the following is true:

You already have explorer running or

You have another shell set in the registry or shell.ini

( 2 ) Try regedit.com for disabling in the registry or controldisable on the start button/menu


Who else would I be?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0