Sign in to follow this  
Followers 0
ashley

broken button

3 posts in this topic

ok the check button is broken... and i dont know why... any ideas.

CODE
; ~~~~~ PC Check-up ~~~~~ ;

; ~~~~~ What does it do? ~~~~~ ;

; ~~~~~ PC Check-up will check your PC for programs that defend your PC(defenders, Anti-virus') ~~~~~ ;

; ~~~~~ This is a BETA Version, This will contain bugs ~~~~~ ;

; ~~~~~ Made by Ashley ~~~~~ ;

#include <GUIConstants.au3>

#include <IE.au3>

Global $P_bar

_IEErrorHandlerRegister ()

;GUI

$MAIN_GUI = GUICreate("PC Check-up!", 1000, 600)

;Welcome

$Label1 = GUICtrlCreateLabel("Welcome to PC Check-up!", 4, 8, 600, 25)

GUICtrlSetFont(-1, 15)

; Inf5

$whatdoesitdo = GUICtrlCreateGroup("What does it do?", 4, 34, 293, 57)

$Label2 = GUICtrlCreateLabel("This will make sure that your PC is 100% protected", 16, 48, 241, 17)

$Label3 = GUICtrlCreateLabel("It will also recommend programs to keep it 100% protected", 16, 64, 277, 17)

$Status = GUICtrlCreateLabel("Status: STILL", 810, 576, 200, 17)

GUICtrlCreateGroup("", -99, -99, 1, 1)

;buttons

$Post = GUICtrlCreateButton(" Post ", 945, 540, 50, 25)

$Check = GUICtrlCreateButton(" Check ", 945, 570, 50, 25)

$Update = GUICtrlCreateButton( "Update ", 890, 540, 50, 25)

;Listview'Select

;1

$Def_ListView = GUICtrlCreateListView("Files|Status", 4, 97, 294, 235, $LVS_REPORT, BitOR($WS_EX_CLIENTEDGE, $LVS_EX_GRIDLINES))

GUICtrlSendMsg(-1, 0x101E, 0, 150)

GUICtrlSendMsg(-1, 0x101E, 1, 139)

$Def_ListView_0 = GUICtrlCreateListViewItem("Windows Defender | Unchecked", $Def_ListView)

;2

$AV_ListView = GUICtrlCreateListView("Files|Status", 4, 337, 294, 235, $LVS_REPORT, BitOR($WS_EX_CLIENTEDGE, $LVS_EX_GRIDLINES))

GUICtrlSendMsg(-1, 0x101E, 0, 150)

GUICtrlSendMsg(-1, 0x101E, 1, 139)

$AV_ListView_1 = GUICtrlCreateListViewItem("Norton Protection Center | Unchecked", $AV_ListView)

$AV_ListView_2 = GUICtrlCreateListViewItem("Avast! | Unchecked", $AV_ListView)

$AV_ListView_3 = GUICtrlCreateListViewItem("AVG | Unchecked", $AV_ListView)

;IE

$oIE = _IECreateEmbedded ()

GUICtrlCreateObj($oIE, 304, 8, 690, 530)

GUISetState(@SW_SHOW)

While 1

$nMsg = GUIGetMsg()

Switch $nMsg

Case $GUI_EVENT_CLOSE

Exit

Case $check

check()

Case $post

_IENavigate ($oIE, "http://www.autitscript.com/forum/index.php?showtopic=60555")

Case $Update

MsgBox(48, "Info...", "Automatic Update is not available in this version")

EndSwitch

WEnd

Func check()

MsgBox(48, "Info...", "Checking")

;Progress bar

$P_bar = GUICtrlCreateProgress(4, 575, 800, 17)

GUICtrlSetData(-1, 100)

endFunc

any ideas.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

$status label is covering up that button.

Now is this bug really worth two topics? You should be ashamed. :)

Edited by Siao

"be smart, drink your wine"

Share this post


Link to post
Share on other sites

$status label is covering up that button.

Now is this bug really worth two topics? You should be ashamed. :)

OMG.. i am lol...

thanks...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0