Jump to content
Sign in to follow this  
deadangel

Control IE Warning Box

Recommended Posts

deadangel

When I select one drop down menu on web page, IE will pop up one warning box, but I can't use "CntrolClick"to click "OK" button of warning box even if it has controlID.

I need you help for this issue.

thanks

Edited by deadangel

Share this post


Link to post
Share on other sites
DaleHohm

You'll need to show some code. Also, suggest you use SciTe debug mode (see my sig) to insure you know exacly how far your code gets.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
deadangel

You'll need to show some code. Also, suggest you use SciTe debug mode (see my sig) to insure you know exacly how far your code gets.

Dale

thanks for your suggestion, I will try it.

Share this post


Link to post
Share on other sites
deadangel

When I select one drop down menu on web page, IE will pop up one warning box, but I can't use "CntrolClick"to click "OK" button of warning box even if it has controlID.

I need you help for this issue.

thanks

below is my code

#include <GUIConstants.au3>
#include <IE.au3>
$oIE = _IECreate("http://192.168.1.1/cfg_qos_bw_nwan1.htm",1)
$oForm = _IEFormGetObjByName ($oIE, "form1")
$oSelect = _IEFormElementGetObjByName ($oForm, "qos_enabled")
if _IEFormElementGetValue($oSelect) == 1 Then
_IEFormElementOptionselect($oSelect,0,1,"byValue")
else
_IEFormElementOptionselect($oSelect,1,1,"byValue")
$oIE1 =_IEAttach("Microsoft Internet Explorer","DialogBox")
_IEQuit($oIE1)
EndIf
$oSelect = _IEFormElementGetObjByName ($oForm, "but_save")
_IEAction($oSelect,"click")

Share this post


Link to post
Share on other sites
DaleHohm

And what is the output to the SciTe console using SciTe debug mode? This will tell you how far your code gets.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
deadangel

And what is the output to the SciTe console using SciTe debug mode? This will tell you how far your code gets.

Dale

I found Autoit can not handle the pop up windows when use _IECreate to call EXPLORE.EXE open web pages.

Share this post


Link to post
Share on other sites
DaleHohm

I found Autoit can not handle the pop up windows when use _IECreate to call EXPLORE.EXE open web pages.

I really doubt that is true, but really cannot comment on your issue since you have not provided the requested information.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
deadangel

I really doubt that is true, but really cannot comment on your issue since you have not provided the requested information.

Dale

Hi Dale

Thanks for your help, I have resolved this issue by vicarious solution.

use _IEFormElementOptionselect($oSelect,1,1,"byValue",0)

0 = do not fire onchange or onclick event after setting value

the pop up warning will not display.

Edited by deadangel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.