Jump to content
Sign in to follow this  
Romm

Vista + IE7 <> Create Hidden IE, Then Send, Then Close this hidden page

Recommended Posts

Romm

Ok here it is

Func _Example($q = "hello world")
    $oIe = _IECreate("http://www.wbot.info/log/log.php?q=" & $q, 0, 0)
   WinClose("http://www.wbot.info")
EndFunc

It opens just a new child page in IE7. It is imposible now to hide page and then close it. :)

Need help...

Share this post


Link to post
Share on other sites
DaleHohm

Add #RequireAdmin to your script if you can. See my sig for Vista issues -- some docs about this will be in the next beta helpfile.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×