Jump to content
Sign in to follow this  
MattX

New created GUIs won't close

Recommended Posts

MattX

This is driving me nuts - two of the GUIs in this script - [ Case $nMsg = $infoitem2 & Case $nMsg = $Icon14 ] won't close when you click on the 'X' but they minimize !! Why ? I've tried everything - in fact if you choose the Case $nMsg = $Icon14 and click twice on the logoff / reboot box, the whole script exits when I have an Exitloop and not an Exit statement !!

I would apprecaite some help otherwise I feel I have wasted my time with this....

Edited by MattX

Share this post


Link to post
Share on other sites
Jos

Why are you using : GUIGetMsg(1) ?

This returns an Array ...

and you need to add a GUIDelete() after the While-Wend loop to delete the GUIs ...

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
MattX

Why are you using : GUIGetMsg(1) ?

This returns an Array ...

That must have been left in when I was trying to use the GUISwitch function [ to see if this would fix it ] to force the window to be the main one.

My understanding though is a new GUI is the default - I am at a loss why they minimize but won't close !!

Share this post


Link to post
Share on other sites
MattX

Why are you using : GUIGetMsg(1) ?

This returns an Array ...

and you need to add a GUIDelete() after the While-Wend loop to delete the GUIs ...

Arrrrrr !! Thats it - you have saved my Bacon. I am soooooooo greatful,

Share this post


Link to post
Share on other sites
Jos

That must have been left in when I was trying to use the GUISwitch function [ to see if this would fix it ] to force the window to be the main one.

My understanding though is a new GUI is the default - I am at a loss why they minimize but won't close !!

Did you see my Edit in the previous post ? :) Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
MattX

Did you see my Edit in the previous post ? :)

After I took out the GUIGetMsg(1) from my original I did !! :-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×