Sign in to follow this  
Followers 0
qwert

Quick question about SciTe4

7 posts in this topic

The SciTE4 FAQ gives the following instructions for enabling:

Goto Options | Open Global Options File and uncomment

autocompleteword.automatic=1

But I want to disable it

-- and autocompleteword.automatic=0 in my global file, which would seem to mean OFF -- but it's ON.

What's the proper way to turn it off? And is there any menu option for toggling it? (I can't find one).

Thanks for any help.

Share this post


Link to post
Share on other sites



AutoComplete Automatic is switched off ... This would do an autocomplete when there is only one possibility.

You want to disable AutoTocomplete all together and not get any drop down box with suggestions ?


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

You want to disable AutoTocomplete all together and not get any drop down box with suggestions ?

Yes, I don't want the drop down choices or the autocompletion.

Share this post


Link to post
Share on other sites

Notepad ? :D

When you are using the Full SciTE4AutoIt3 setup its difficult because it has LUA functions forcing the AutoComplete and ToolTips for the parameters.

We have spent a lot of time to make the creation of scripts as easy and fast as possible so really cannot understand why you would want this to be disabled.


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

... really cannot understand why you would want this to be disabled.

First of all, let me say that SciTE4 is the finest editing tool I have ever used. I like it very much. The close integration with the language being edited ... the integration with the other tools ... the colorization of text ... all great. As they say, however, the devil is in the details -- and that's where autocomplete presents a problem for me.

At least half of the errors I make in editing are due to hitting a carriage return at the wrong point (while the selection box is displayed) and having unintended text inserted. If I used only SciTE4 all day and every day, I doubt if this would present a problem. The reality is that I'm back and forth between packages -- word processing, email, database applications -- throughout the day and the different behavior simply trips me up. For the most part, I am editing existing scripts, not composing new ones, and this one feature has been a problem -- nothing else.

I appreciate you taking the time to ask why this might be a problem and I certainly appreciate the effort that has gone into these tools. I was hoping this issue was more common (than it probably is) and that an on/off switch existed. If not, I can accept that. Again, it's a great tool.

Share this post


Link to post
Share on other sites

Its not a big deal to add an property in the properties files and test for that to always disable the AutoComplete popup.

I will add this option to au3.properties which allows you to override it in SciTEUser.properties:

autocomplete.au3.disable=0

So adding this to SciTEUSer.properties will disable AutoComplete totally.

autocomplete.au3.disable=1

This will be in the next version of SciTE4AutoIt3 available soon.


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

This will be in the next version of SciTE4AutoIt3 available soon.

I'll certainly be looking forward to that enhancement. Many thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0