Sign in to follow this  
Followers 0
JSThePatriot

I must be missing something...

5 posts in this topic

I copied this out of the help file... it doesnt seem to do anything. I press F5 on SciTE or try to run it without SciTE. Neither way brings up anything. Maybe I am just missing something. I cant find anything else in the help file in the GUICreate() that would direct me properly.

#include GUIConstants.au3

GUICreate("myGUI")
GUISetState(@SW_SHOW)

While 1
    $msg = GUIGetMsg()
    If $msg = $GUI_EVENT_CLOSE Then ExitLoop
Wend

Let me know,

JS


AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites



For your info:

GUI threads/topics should be opened in the v3 GUI (Beta Only) section.

Question:

No disrespect but did you download the beta version? (available here)

Share this post


Link to post
Share on other sites

I copied this out of the help file... it doesnt seem to do anything. I press F5 on SciTE or try to run it without SciTE. Neither way brings up anything. Maybe I am just missing something. I cant find anything else in the help file in the GUICreate() that would direct me properly.

#include GUIConstants.au3

GUICreate("myGUI")
GUISetState(@SW_SHOW)

While 1
    $msg = GUIGetMsg()
    If $msg = $GUI_EVENT_CLOSE Then ExitLoop
Wend

Let me know,

JS

<{POST_SNAPBACK}>

Did you copy&paste it ?

You are missing the <> around GUIConstants.au3....


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

#include GUIConstants.au3
It's a bug. There is no < > in the #include line.

Displayed in the manual this. A mistake in manual.

Edited by MHz

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

@SlimShady

The reason I opened the thread here and not there is because I have seen probably over 100 threads come through here that are GUI related. I havent once seen anyone refer it to the v3 GUI (Beta Only). So I figured there would be no problem.

Yes I did download the beta version and installed it :)

@JdeB

Thanks I must have missed that. I thought I saw it in the help file the way Mhz said it was, but you are correct the help file has the <>'s

@MHz

Might want to update your helpfile. It has the <>'s :)

Edit: Its not a mistake on the GUICreate() part though I could have swore I have seen it that way before.

Thank you guys,

JS

Edited by JSThePatriot

AutoIt Links

File-String Hash Plugin Updated! 04-02-2008 Plugins have been discontinued. I just found out.

ComputerGetInfo UDF's Updated! 11-23-2006

External Links

Vortex Revolutions Engineer / Inventor (Web, Desktop, and Mobile Applications, Hardware Gizmos, Consulting, and more)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0