Sign in to follow this  
Followers 0
Cr8iveOD

Is AutoIT right for me?

8 posts in this topic

I've got the silent install of Adobe Creative Suite CS3 Master Collection to work from over a network source (using a command line and silent switch along with a deployment.xml file) but I would ultimately like to deploy from DVD at the OS install. I can use variables to find the deployment file (install.xml) in the command line, but It does not seem to recognize variables in the xml file. I always get an exit code 7 and in the logfile it states that it can't find the INSTALLDIR location. When I use drive letters it works no problem. So even though I can run the installer DVD from any drive letter it will only install if the system disk is C: and the DVD drive is D: (as stated in the install.xml file)

Unattended installs is just something I picked up recently ... I guess as a hobby. That might sound strange so forgive my ignorance on the subject. I recently learned of AutoIT and it looks like it is great utility. I'm just not sure if I need all the "bells and whistles". Its seems as I was very close to getting it to work with the current deployment method. Is there any advice anyone could give me on which direction to head?

trying to install on Vista if that makes a difference.

thanks ahead of time.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

hy there folks,

i recently had the same problem. I just started to get familiar with autoit-scripts and i'm working hard to understand everything.

my buddy just gave me a .exe file of the script for photoshop cs2. i thought it could be a fairly good comparisson to the script for cs3 master.

unluckily it has a MD5-hash/passphrase.

- removed unwanted information-

whats wrong with this script?

i've been working 3 days now, just to see and read this script...

can anybody give me a hint?

regards

Edited by Jos
removed unwanted information

Share this post


Link to post
Share on other sites

hy there folks,

i recently had the same problem. I just started to get familiar with autoit-scripts and i'm working hard to understand everything.

my buddy just gave me a .exe file of the script for photoshop cs2.

Ask your buddy for the source and please don't hijack this thread ...

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

sorry you guys...

didn't know where to post this.

hey Jos... where should i post this then?

if my buddy knew the source, i wouldn't post problems here^^

can you help me Jos???

Share this post


Link to post
Share on other sites

sorry you guys...

didn't know where to post this.

hey Jos... where should i post this then?

if my buddy knew the source, i wouldn't post problems here^^

can you help me Jos???

When you have questions just create your own thread... and no I will not help you when its not your script, ask the creator of the script or create your own.

:D


Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

really? all of that and not even a hint?! Oh well despite my rudimentary knowledge of the program I was able to write a VERY basic script after watching the tutorial on how to install winrar. To my surprise it actually worked when testing the install on my local machine. However when I tried the install from my OS DVD it failed for a couple reasons. 1. Resolution was < 1024x768. I should be able to change that in the windows setup. 2. Asked to insert DVD into drive D: ... I had done a couple things to the Installer xml files to make it silent. It worked from my local HD to install but maybe I need a fresh copy of the installer. I'll try tonight and see what happens.

*Thanks Mods! i feel safe :D

Share this post


Link to post
Share on other sites

If it is a Installshield installation done silently from a read only media, then it may fail as the installer will attempt to create a log file in the same directory which causes failure. Depending on what type of Installshied installer it is may determine the use perhaps the /f2 switch to set a path to save the log file.

:D

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

Still got the "Insert CS3 Master Collection D1.... " So I should be able to copy to the system drive during the install using the OEM folders. Then I should be able to start the installer from the local HD and install. And after all installs, add a command to delete the CS3 install folder. This *should* work. I just wonder how the installer works from the retail DVD or as a DVD image if the log file location is really the issue. I am not trying to do a silent install anymore... just an unattended version. I don't mind if the windows show as long as they progress. This time I tried with a fresh rip of the installer and without any modifications. I modified no xml files and used no switches. any insight would be appreciated.

thanks

Edited by Cr8iveOD

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0