Sign in to follow this  
Followers 0
MuffettsMan

send("{LALT Down}") bugged?

3 posts in this topic

trying to use a send("{LALT Down}") into a game and it seems to get hung on the LALT bit - if i simply say ALT Down it works fine when i try to make it conditional to which alt key it flakes...

tested this on a XP and vista box both with the same results.... to take the game out of the question you can replicate the same problem using wordpad....

THIS WORKS:

WinActivate("Document - WordPad")
sleep (1000)
send("Working Test (Alt Menu will come up and stay up)")
sleep(2000)
send("{ALT Down}")
send("F"); Open the file menu
send("{ALT Up}")

however now trying to specify which alt key it flakes out....

THIS DOESN'T WORK:

WinActivate("Document - WordPad")
sleep (1000)
send("FAILING Test (Alt Menu won't up)")
sleep(2000)
send("{LALT Down}")
send("F"); Open the file menu
send("{LALT Up}")

It actually seems to hit the alt button for a split second and then get hung up as if the alt key is still down though never did the next keypress... am i doing something wrong or is there a better way of accomplishing a send("{LALT Down}")?

Finally yes i know there are other / better ways of accessing menus - i just did this to make a non game related example


Don't let that status fool you, I am no advanced memeber!

Share this post


Link to post
Share on other sites



edit: AFAIK (helpfile) you can only send {ALTDOWN} or (LALT}

meh i was hoping it was just not documented in the help file as the syntax seemed to pass Scite and it does in fact at least attempt to click even if incorrectly >.<


Don't let that status fool you, I am no advanced memeber!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0