Jump to content
Sign in to follow this  

Vista x64 - v3.2.10.0

Recommended Posts


Good morning all. I've seem to run into a problem here when it comes to the lastest version of Autoit and Vista x64. To get ready for Age of Conan, i've decided to reformat my hard drive lastnight to install Vista Enterprise Edition x64 version. Everything went very smooth until I tried to run my scripts I have for a couple of games. No not cheating ones btw, but just simple key commands so I don't have to wear out my G15 keys!! :) ...... Anyways, what's happening is that when I run the script, nothing in the game happens when I select the hot keys for execute. After doing some research on the fourms lastnight I came across this --

Windows Vista brings new security features to restrict the running of files that require administrative rights. Even administrator users will be prompted every time an executable runs which will perform some administrative operation (such as writing to the registry key HKEY_LOCAL_MACHINE or writing to the C:\Windows directory). This is called User Account Control (UAC).

By default AutoIt scripts run with standard user permissions but AutoIt has been coded to allow the script writer the option to "tag" a script in order to tell AutoIt if it needs to run with full admin rights or not.

To force a script to attempt to run itself with administrative rights add the #requireadmin directive at the top of your script as follows:

; This script requires full Administrative rights


MsgBox(0, "Info", "This script has admin rights! ")

When the script runs AutoIt will check if it already has full admin rights and if not it will cause the operating system to prompt the user for permission as shown in "UAC Prompts". If permission is not given by the user the script will terminate.

I modified my script to the above and now comes the weird part.... I can only run the script once?!?! If for some reason I exit the script ( IE bathroom break, beer break , etc...) and I come back to the game and re-execute the script again, nothing happens when I hit the hot keys.......I've been doing this type of 'restarting' of the scripts on this laptop with XP tons of times without any problems so I think it has to do with Vista not sending the key commands... Has anyone else ran into this problem of vista not sending key commands and if so, what was your solution? Thanks in advance for the help ... I'd hate to re-ghost the box back to XP .....

Edited by d00dness

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.