Sign in to follow this  
Followers 0
AutoChris

Changing the icon

7 posts in this topic

Why is it that whenever I change the AutoIt icon after compiling my script, the executable no longer works? Is this supposed to be some sort of security feature?

Changing the icon isn't absolutely necessary, but it is nice to have a different icon for different scripts so that when I am running multiple scripts I can see which one is running based on the icon that shows up in the taskbar.

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

The icon has to be a certain size--file size or color depth or something. The provided icons in Aut2Exe\Icons should work; other icons probably won't....

EDIT: Okay, I'm wrong :whistle: New versions of AutoIt like virtually any icon!

Anyone know a good icon editor?

Edited by CyberSlug

Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

http://www.axiomx.com/PixelToolbox/index.htm

No a bad little program .... and it's FREE!!! one of my favorite four letter words ... :whistle:

Not sure if it changed but the icons had to be 32 x 32 Pixels 16 colors and be 766 bytes in size


We have enough youth. How about a fountain of SMART?

Share this post


Link to post
Share on other sites

In v3 the icons can be any size/format. Not sure why the original poster was not specifying the icon they wanted during compilation.

The compiled exectuables are checksumed and encrypted and any changes to them will indeed stop the exe working. It is part security feature and is also helps prevent unauthorised decompiling.

Share this post


Link to post
Share on other sites

In v3 the icons can be any size/format.  Not sure why the original poster was not specifying the icon they wanted during compilation.

Ah, maybe the poster didn't know about Aut2Exe.exe (which should be located in AutoIt's program directory) and, instead, simply compiled the sript from the context menu.

I had assumed the poster was chaning the icon this way.... but I see I misread the post!


Use Mozilla | Take a look at My Disorganized AutoIt stuff | Very very old: AutoBuilder 11 Jan 2005 prototype I need to update my sig!

Share this post


Link to post
Share on other sites

You are correct. I hadn't thought of using Aut2Exe to compile my scripts. I had used an icon editor (Axicons, actually) to modify the icons after compilation in AutoIt v2 so I guess I was spoiled doing it that way.

Now that I have started using the Aut2Exe, everything works just fine.

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0