Sign in to follow this  
Followers 0
bob57

window update breaks script (maybe?)

3 posts in this topic

Hi,

I had what was an almost completed script. However after installing a new version of XP Office and /all/ security update my script now breaks, at the second step. I'm wondering if this is a security related thing. I get:

>"C:\Program Files\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "Z:\autoit\invoicing\ework-1.au3"

--> COM Error Encountered in ework-1.au3

----> $IEComErrorScriptline = 674

----> $IEComErrorNumberHex = 80020009

----> $IEComErrorNumber = -2147352567

----> $IEComErrorWinDescription = Access is denied.

----> $IEComErrorDescription = Access is denied.

----> $IEComErrorSource =

----> $IEComErrorHelpFile = C:\WINDOWS\system32\mshtml.hlp

----> $IEComErrorHelpContext = 0

----> $IEComErrorLastDllError = 0

--> COM Error Encountered in ework-1.au3

----> $IEComErrorScriptline = 2449

----> $IEComErrorNumberHex = 80020009

----> $IEComErrorNumber = -2147352567

----> $IEComErrorWinDescription = Access is denied.

----> $IEComErrorDescription = Access is denied.

----> $IEComErrorSource =

----> $IEComErrorHelpFile = C:\WINDOWS\system32\mshtml.hlp

----> $IEComErrorHelpContext = 0

----> $IEComErrorLastDllError = 0

C:\Program Files\AutoIt3\Include\IE.au3 (2499) : ==> Object referenced outside a "With" statement.:

SetExtended($oTemp.GetElementsByTagName ($s_TagName).length)

SetExtended($oTemp.GetElementsByTagName ($s_TagName)^ ERROR

>Exit code: 1 Time: 18.092

I can see lots of options in IE for controlling what can be run from where etc. But....

Is this a security related problem? If it is is there any idea what options to turn off/on in IE or wherever etc. please?

Cheers,

Bob

Share this post


Link to post
Share on other sites



I'm no expert on IE.au3 but my first hunch is that you don't get a proper object anymore or the object does something it does not have access to anymore. The second part of the error indicates (I think) that you pass one a object that is not valid anymore.

Any chance you could reproduce some of the error with a few lines of code?

Witch AutoIt version do you use?

Do you use XP/Vista/w2k (OS)?

Share this post


Link to post
Share on other sites

Hi, Well version info;

>"C:\Program Files\AutoIt3\SciTE\AutoIt3Wrapper\AutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in "Z:\autoit\invoicing\ework-1.au3" /autoit3dir "C:\Program Files\AutoIt3" /UserParams

+>16:17:54 Starting AutoIt3Wrapper v.1.10.1.4 Environment(Language:0409 Keyboard:00000809 OS:WIN_XP/Service Pack 2 CPU:X86)

>Running AU3Check (1.54.10.0) from:C:\Program Files\AutoIt3

+>16:17:54 AU3Check ended.rc:0

>Running:(3.2.10.0):C:\Program Files\AutoIt3\autoit3.exe "Z:\autoit\invoicing\ework-1.au3"

>Error code: 0

I've added in the trace feature from the lastest editor, and and extra debug line (_IEPropertyget)

I want the iFrame eFormContents, and I've got it in the innerhtml...

==========================================================

@ Trace(200) : ConsoleWrite(_IEPropertyGet($handle,"innerhtml") & "WANTING: " & $name & @CRLF)

<!-- Activity Bar Section -->

<DIV class="stretch ABColor" id=eActivityBar style="LEFT: 0px; VISIBILITY: hidden; POSITION: absolute; TOP: 0px" onclick=ActivityBarClick()>

<TABLE class=stretch cellSpacing=0 cellPadding=0 border=0>

<TBODY>

<TR>

<TD vAlign=center align=middle><IMG alt="" src="images/Common/ProgressIndicator.gif">

<DIV class=ABCaption id=eABCaption></DIV></TD></TR></TBODY></TABLE></DIV><!-- Form Section -->

<DIV id=eFormArea style="VISIBILITY: visible">

<TABLE class=stretch id=eHostTable style="BACKGROUND-COLOR: #b5c9dd" cellSpacing=0 cellPadding=0 border=0><!-- Form Contents Section -->

<TBODY>

<TR>

====================

it's here

==========================

<TD><SPAN id=eFormContentsArea style="VISIBILITY: visible"><IFRAME class=stretch id=eFormContents title="e-Work Form Contents" border=0 name=eFormContents src="eactionformcontents.ashx?Authenticate=true&amp;Service=e-Work+Server&amp;CancelURL=eWorkCloseWindow&amp;LaunchURL=eWorkCloseWindow" frameBorder=0></IFRAME></SPAN></TD></TR><!-- Confirm Cancel Section -->

<TR id=eConfirmCancelArea height=1>

<TD id=eSeparator background=images/Actions/bottombar_tile.gif height=34>

<DIV>

<TABLE height=34 cellSpacing=0 cellPadding=0 width="100%" border=0>

<TBODY>

<TR>

<TD id=cellActionsArea noWrap width="100%"></TD>

<TD id=cellConfirm noWrap><A onclick="return OnConfirmClick();" tabIndex=1000 href="#"><IMG id=btnConfirm onmouseover=ConfirmMouseOver(); title=Submit onmouseout=ConfirmMouseOut(); height=23 alt=Submit src="images/GeneralButtons/but_ok.gif" width=38 border=0></A><IMG height=1 alt="" src="images/Common/spacer.gif" width=10></TD>

<TD id=cellCancel noWrap><A onclick="return OnCancelClick();" tabIndex=1001 href="#"><IMG id=btnCancel onmouseover=CancelMouseOver(); title=Cancel onmouseout=CancelMouseOut(); height=23 alt=Cancel src="images/GeneralButtons/but_cancel.gif" width=38 border=0></A><IMG height=1 alt="" src="images/Common/spacer.gif" width=10></TD></TR></TBODY></TABLE></DIV></TD></TR></TBODY></TABLE></DIV>

<script defer>

//PDF detection

if(eFormContents.frameElement)

eFormContents.frameElement.onreadystatechange = fnFormContentsInit;

else

prepareForPDF();

</SCRIPT>WANTING: eFormContents

>Error code: 0

=====================================================

but the script dies when i try and get the iframe object from the parent object

========================================================

@@ Trace(202) : Local $frame

>Error code: 0

@@ Trace(204) : $frame = _IEFrameGetObjByName($handle, $name)

--> COM Error Encountered in ework-1.au3

----> $IEComErrorScriptline = 674

----> $IEComErrorNumberHex = 80020009

----> $IEComErrorNumber = -2147352567

----> $IEComErrorWinDescription = Access is denied.

----> $IEComErrorDescription = Access is denied.

----> $IEComErrorSource =

----> $IEComErrorHelpFile = C:\WINDOWS\system32\mshtml.hlp

----> $IEComErrorHelpContext = 0

----> $IEComErrorLastDllError = 0

--> COM Error Encountered in ework-1.au3

----> $IEComErrorScriptline = 2449

----> $IEComErrorNumberHex = 80020009

----> $IEComErrorNumber = -2147352567

----> $IEComErrorWinDescription = Access is denied.

----> $IEComErrorDescription = Access is denied.

----> $IEComErrorSource =

----> $IEComErrorHelpFile = C:\WINDOWS\system32\mshtml.hlp

----> $IEComErrorHelpContext = 0

----> $IEComErrorLastDllError = 0

C:\Program Files\AutoIt3\Include\IE.au3 (2499) : ==> Object referenced outside a "With" statement.:

SetExtended($oTemp.GetElementsByTagName ($s_TagName).length)

SetExtended($oTemp.GetElementsByTagName ($s_TagName)^ ERROR

->16:18:16 AutoIT3.exe ended.rc:1

>Exit code: 1 Time: 23.328

Cheers,

Bob

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0