Sign in to follow this  
Followers 0
ptrbee

newbie test install

5 posts in this topic

Hi,

I'm new to autoit & i'm trying to install a program called lightscribe to test in vista.

here is what i've done so far prob is it stops on the install wizzard waiting for me to click next. I've tried Send("!1") along with a few other commands but so far none of them worked.

[/code]; This script requires full Administrative rights
#requireadmin

MsgBox(0, "Info", "This script has admin rights! ")

#cs ----------------------------------------------------------------------------

 AutoIt Version: 3.2.10.0
 Author:         myName

 Script Function:
    Template AutoIt script.

#ce ----------------------------------------------------------------------------

; Script Start - Add your code below here

Run ("""LS_Update_1.12.29.2_.exe""-s")
WinWaitActive("LightScribe System Software  1.12.29.2 - InstallShield Wizard", "&Next")
ControlClick("LightScribe System Software  1.12.29.2 - InstallShield Wizard", "", "[Class:  Button; Text:   &Next >; Instance:  1]")[code]

thankz in advance

ptrbee

Share this post


Link to post
Share on other sites



Try

ControlClick("LightScribe System Software  1.12.29.2 - InstallShield Wizard", "", "[Class:Button;Text:&Next >;Instance:1]")

without spaces

hi I'd already done it without the sapces. Reason for spaces is that I copied outout from "autoit window info". I have also tried sending, !y, 1, and {enter} with no joy. So far I can only get MouseClick("left", 741, 667) to work but fro what I understand if I use that & then run the script on another system with a different resolution then MouseClick("left", 741, 667) may not work.

Can anyone with a bit more experiance than me download Lightscribe or winzip 11.1 & tell me where i'm going wrong, on WIndows Vista.

Ptrbee

Share this post


Link to post
Share on other sites

I'm sure there is a way to silently install this software. If you go to a command prompt and type:

LS_Update_1.12.29.2_.exe /?

You will see the available options.

I tried this but there must be something missing for the MSI installer:

;Show traytip status
Traytip("Installing Lightscribe", "LS_Update_1.12.29.2_.exe", 60)

;Install Lightscribe silently
RunWait("LS_Update_1.12.29.2_.exe /S /v /qn")

;Clear traytip
Traytip("", "", 0)

Share this post


Link to post
Share on other sites

Just got an email back from Lightscribe tech support:

Hello Matt,

Thank you for contacting Lightscribe. Try this:

LS_Update_1.12.29.2_.exe /s /v" /qb"

Hope this helps!

Best Regards,

Joshua Stevens

**re: LSQ

And here is the code (I tested it as well):

;LightScribe Silent Install

;Show traytip status
Traytip("Installing Lightscribe", "LS_Update_1.12.29.2_.exe", 60)

;Install Lightscribe silently
RunWait('LS_Update_1.12.29.2_.exe /s /v" /qb"', @ScriptDir)

;Clear traytip
Traytip("", "", 0)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0