Sign in to follow this  
Followers 0
Gmann

Need help with RunWait for an MSI file

4 posts in this topic

I have this long nasty application to install that has a bunch of custom settings so I thought I would try to automate it by writing a script.

I tried to first write it in a .bat file but that did not have enough of options. So now I am trying to use AutoIT. I know very little about programming but thought I would give this a try anyway.

I am trying to run an MSI file with several parameters. This did work in my .bat file but I could not see a way to automate it and have the install show its progress. At this time I am not able to get it to run in my script. I think it has to do with the double quotes. I tried what the help file suggested but I have not been able to get it to work. I was hoping someone would look it over and let me know what I am doing wrong.

Here is the code. I copied it from my .bat file so I know that it is right for running from the command prompt. At this time I am just trying to run this one line.

CODE
RunWait("msiexec.exe /qn /i "T:\ises\nx4\win\base\nx040\UGS NX 4.0.msi" ADDLOCAL="ALL" INSTALLDIR="C:\UGS\NX4" LICENSESERVER=27000@benjamin.dci.com")

So my second question for this is, is thre a way to have a progress indicator display while this file runs? The way it works now is the screen flashes and it does not look like anything is happening. If I wait fore 15 minutes or so I can see that all the files loaded but it would be nice to know something is happening.

Any help that can come my way would be appreciated.

Thanks

Share this post


Link to post
Share on other sites



It's Ugly but try

$var = RunWait("msiexec.exe /qn /i " & "T:\ises\nx4\win\base\nx040\" & '"UGS NX 4.0.msi"' & " ADDLOCAL=" & '"ALL"' & " INSTALLDIR=" & '"C:\UGS\NX4"' & " LICENSESERVER=" & '"27000@benjamin.dci.com"')

and as far as a progress indicator, I'm the wrong person for that one.

RunWait("msiexec.exe /qn /i "T:\ises\nx4\win\base\nx040\UGS NX 4.0.msi" ADDLOCAL="ALL" INSTALLDIR="C:\UGS\NX4" LICENSESERVER=27000@benjamin.dci.com")

So my second question for this is, is thre a way to have a progress indicator display while this file runs? The way it works now is the screen flashes and it does not look like anything is happening. If I wait fore 15 minutes or so I can see that all the files loaded but it would be nice to know something is happening.

Any help that can come my way would be appreciated.

Thanks

Share this post


Link to post
Share on other sites

single quotes inside double quotes... (or the other way around)

RunWait("msiexec.exe /qn /i 'T:\ises\nx4\win\base\nx040\UGS NX 4.0.msi' ADDLOCAL='ALL' INSTALLDIR='C:\UGS\NX4' LICENSESERVER=27000@benjamin.dci.com")

Kerros===============================================================How to learn scripting: Figure out enough to be dangerous, then ask for assistance.

Share this post


Link to post
Share on other sites

So my second question for this is, is thre a way to have a progress indicator display while this file runs? The way it works now is the screen flashes and it does not look like anything is happening. If I wait fore 15 minutes or so I can see that all the files loaded but it would be nice to know something is happening.

Any help that can come my way would be appreciated.

Thanks

use /qb or /qr instead of /qn to see progress indicator...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0