Sign in to follow this  
Followers 0
BadBoyDeGekste

keep getting this error

2 posts in this topic

#1 ·  Posted (edited)

Do; Start a post-test loop
        Sleep ( 50 ); Just to give your CPU a break from this tight loop.  You won't notice changes faster than this anyway.
    $hai = PixelGetColor ( 435 , 150 )
    if $hai = 0xFFFFFF then ContinueLoop; Goes back to start of loop

    $lol = PixelGetColor ( 265 , 349 )
    If $lol = 0xFFFFFF then; It looks like you want all of this if the condition is true.
         MouseClick ( 300 , 600 , 1 , 250 )
         Sleep ( 10000 )
         MouseClick ( 300 , 600 , 1 , 250 )
         sleep ( 1000 )
         MouseClick ( 300 , 600 , 1 , 250 )
    Endif

    MouseClick ( "left" , 265 , 349 , 240 , 250  )
    MouseClick ( "left" , 400 , 700 , 1 , 250  )

    $rofl = PixelGetColor ( 400 , 700 )
Until $rofl = 0xFFFFFF then ContinueLoop; Leave the loop if the condition is true; otherwise back to the top of the loop.

Error; variable used without being declared

really irritating :)

can anyone help me?

Edited by BadBoyDeGekste

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

C:\Au3\ForumTesting.au3(20,24) : ERROR: syntax error

Until $rofl = 0xFFFFFF then

~~~~~~~~~~~~~~~~~~~~~~~^

SciTe Editor would give you all your errors in the output pane. Edited by SmOke_N

Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0