Sign in to follow this  
Followers 0
RodT

SQLite query crashes AutoIt - Suggestions?

1 post in this topic

I have a SQLite query which consistently causes AutoIt to crash. The Windows (Vista) message which is displayed is "AutoIt v3 Script has stopped working". The message displayed in the log panel by AutoIt is "!>22:31:17 AutoIT3.exe ended.rc:-1073741819".

If I take one column, a text column, out of the query, it works with no problems at all. If I put that column back into the query, it fails consistently. It is a text-type column. MOST of the fields in the query are of the same type; I cannot see anything different about this column.

THIS query works, no problems at all:

$qTxt = "SELECT LastName, FirstName, Phone, Email, Address, City, State"

$qTxt &= ", Zip, Note, Attends, List, Prior, LastSvc, Active" ;, InactReason"

$qTxt &= " FROM volunteers WHERE Sysid = " & String($iSysId) & ";"

THIS query fails every time:

$qTxt = "SELECT LastName, FirstName, Phone, Email, Address, City, State"

$qTxt &= ", Zip, Note, Attends, List, Prior, LastSvc, Active, InactReason"

$qTxt &= " FROM volunteers WHERE Sysid = " & String($iSysId) & ";"

The only difference is the inclusion of "InactReason" as the last column in the query. It is a text column, defined just the same way as LastName, FirstName, etc.

Can anyone suggest what I should be looking for? I'm stumped!!!

THANKS!!!!

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0