Jump to content
Sign in to follow this  
exportsodas

vista trouble

Recommended Posts

exportsodas

when i tell autoit to send any keyboard strokes it doesnt work

send("hello") doesnt send hello onto my notepad, the examples in the examples folder like calculator or notepad1/2, nothing is imputed. this is not a UAC problem. plz help me

Share this post


Link to post
Share on other sites
botanic

use the #requireadmin command at the begining

Share this post


Link to post
Share on other sites
exportsodas

i tired that it didnt work either

Share this post


Link to post
Share on other sites
MHz

Here is a change to the notepad example to also hopefully suit Vista.

Run("notepad.exe")
WinWaitActive("Untitled - Notepad")
Send("This is some text.")
WinClose("Untitled - Notepad")
WinWaitActive("Notepad", "Cancel")
Send("!n")

I cannot help you with the other examples you mention as I am running on XP atm.

:)

Share this post


Link to post
Share on other sites
exportsodas

x.x thx for ur help, but it didnt work either, notepad opened then closed right after.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.