Sign in to follow this  
Followers 0
EscapeTheFate

quick help =P

15 posts in this topic

#1 ·  Posted (edited)

#include <IE.au3>

start()
func start()
        While 1
            MsgBox(0, "start", "start")
$oIE = _IEAttach("haha")

_IEImgClick ($oIE, "http://www.geocities.com/shimlar101/sitemap.jpg")
    WEnd

endfunc

--> IE.au3 V2.3-1 Warning from function _IEImgClick, $_IEStatus_NoMatch

why

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

#include <IE.au3>
$oIE = _IEAttach("haha")
_IEImgClick ($oIE, "sitemap.jpg", "src")

same result --> IE.au3 V2.3-1 Warning from function _IEImgClick, $_IEStatus_NoMatch

what am i doing wrong?:S

Edited by EscapeTheFate

Share this post


Link to post
Share on other sites



The image cannot be found. That's about as basic an error as I've ever seen.

Share this post


Link to post
Share on other sites

Why though, the image is there? I can see it with my own eyes.

Share this post


Link to post
Share on other sites

Can I see the page?

Share this post


Link to post
Share on other sites

That's the image, I was asking for the page it was located on.

Share this post


Link to post
Share on other sites

^^ fixed it

Share this post


Link to post
Share on other sites

The page is not found. Are you sure that it's "sitemap.html"?

Share this post


Link to post
Share on other sites

positive. :S I can post the source of the page if you wish?

Share this post


Link to post
Share on other sites
Posted Image <-- even uploaded a screenie so i dont feel so crazy haha

Share this post


Link to post
Share on other sites

#11 ·  Posted (edited)

Ah, that's what's wrong with the link you gave me. The page is "haha.html". I'll take a look at it.

Ah, the problem is that since you are using geocities, there are frames. Frames are evil when trying to dissect the DOM tree. I don't know how to handle frames properly when accessing DOM, but I know that is what your problem is. The page shown here, contains a frameset of the advertisement on the side and your page. You may have to find someone else to help you here, or search around the forum for frame help I guess.

Edited by Richard Robertson

Share this post


Link to post
Share on other sites

oh sorry -__- been coding away for hours. then decided to try this =P

Share this post


Link to post
Share on other sites

Eh, see edit above, I changed that post, but I'm not sure if you caught that before posting.

Share this post


Link to post
Share on other sites

ohh great =D I see, I didn't take the geocities frame stuff into mind. Thanks i know how to fix this =D

Thanks alot!

Share this post


Link to post
Share on other sites

Glad to help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0