Sign in to follow this  
Followers 0
Dampe

GuiConstants.au3 - Strange error

2 posts in this topic

#1 ·  Posted (edited)

Whenever I am adding

#include <GUIConstants.au3>

To my script I am getting this error:

C:\Program Files\AutoIt3\Include\Constants.au3 (422) : ==> Cannot make existing variables into constants.: 
Global Const $PROCESS_VM_READ = 0x00000010 
Global Const ^ ERROR

I seem to think that another one of my includes might be doing this..

any ideas?

Edited by Dampe

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

We need more information. I (obviously) get no error when I run a script with just #include <GUIConstants.au3>.

I don't even get an error if I run this:

$PROCESS_VM_READ = 'Hi there!'
#include <GUIConstants.au3>

I would guess that you are correct, but really, you already came to that conclusion, so how helpful is this right now?

*Edit: Hit add reply before I was done.. As far as real help goes, the best I can offer is include GUIConstants before everything else. As far as I'm concerned, any script where you're using includes should always have the AutoIt distributed includes at the top, followed by your own.

Edited by Saunders

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0