Sign in to follow this  
Followers 0
jpam

SciTe + AutoIt

5 posts in this topic

can someone explain me why i get all these errors ?

its not only Xskin but all scripts

i did complete new install with AutoIt v3.2.10.0 + Beta v3.2.11.0 (beta)

new install of the last SciTe build

But the problem still remains ! :)

i am getting a headtick from it !@#?

Thanks in advance for any help !

SciTe console;

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(94,26) : WARNING: $WS_POPUP: possibly used before declaration.

$guiHeader2 = $WS_POPUP

~~~~~~~~~~~~~~~~~~~~~~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(107,79) : WARNING: $WS_CLIPSIBLINGS: possibly used before declaration.

GUICtrlCreatePic($elements[0], 0, 0, $tile_size, $tile_size, $WS_CLIPSIBLINGS)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(115,105) : WARNING: $SS_NOTIFY: possibly used before declaration.

GUICtrlCreatePic($elements[1], ($tile_size * ($XS_i + 1)), 0, $tile_size, $tile_size, BitOR($SS_NOTIFY,

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(149,56) : WARNING: $SS_ETCHEDFRAME: possibly used before declaration.

GUICtrlSetStyle($CtrlIDB[$XS_x], $SS_ETCHEDFRAME)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(151,66) : WARNING: $SS_GRAYRECT: possibly used before declaration.

GUICtrlSetStyle($CtrlIDB[$XS_x], $SS_NOTIFY + $SS_GRAYRECT)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(227,103) : WARNING: $SS_BLACKRECT: possibly used before declaration.

$CtrlButton[$ButtonIndex][0] = GUICtrlCreateLabel("", $Bleft, $Btop, $Bwidth, $Bheight, $SS_BLACKRECT)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(229,111) : WARNING: $SS_WHITERECT: possibly used before declaration.

$CtrlButton[$ButtonIndex][2] = GUICtrlCreateLabel("", $Bleft, $Btop, $Bwidth - 1, $Bheight - 1, $SS_WHITERECT)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~~~~~~~~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(231,133) : WARNING: $SS_CENTER: possibly used before declaration.

$CtrlButton[$ButtonIndex][1] = GUICtrlCreateLabel($Btext, $Bleft + 1, $Btop + 1, $Bwidth - 3, $Bheight - 3, $SS_NOTIFY & $SS_CENTER)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(359,128) : WARNING: $BS_BITMAP: possibly used before declaration.

$XS_winB[$XS_b] = GUICtrlCreateButton("", ($XSIPos[2] - $XadjLt) - $XS_IPos1, $XadjDn, $XS_Isize, $XS_Isize, BitOR($BS_BITMAP,

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~~~~~~~~~~~~~~~~~~~~~~~~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(359,141) : WARNING: $WS_VISIBLE: possibly used before declaration.

$XS_winB[$XS_b] = GUICtrlCreateButton("", ($XSIPos[2] - $XadjLt) - $XS_IPos1, $XadjDn, $XS_Isize, $XS_Isize, BitOR($BS_BITMAP, $WS_VISIBLE)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(359,158) : WARNING: $WS_EX_TOPMOST: possibly used before declaration.

$XS_winB[$XS_b] = GUICtrlCreateButton("", ($XSIPos[2] - $XadjLt) - $XS_IPos1, $XadjDn, $XS_Isize, $XS_Isize, BitOR($BS_BITMAP, $WS_VISIBLE), $WS_EX_TOPMOST)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

D:\Program Files\AutoIt3\beta\Include\XSkin.au3(94,26) : ERROR: $WS_POPUP: undeclared global variable.

$guiHeader2 = $WS_POPUP

~~~~~~~~~~~~~~~~~~~~~~~^

D:\snelheidscontrole\skin\Basic_GUI.au3 - 1 error(s), 11 warning(s)

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

some constant declarations has been moved to different include files.

So you must repair your old script to use new (modified) standard include files.

EDIT: see AutoIt changelog for more details.

Edited by Zedna

Share this post


Link to post
Share on other sites

ppfff, Thanks Zedna !

its working again ! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0