Sign in to follow this  
Followers 0
hendrikhe

Picture in a GUI

3 posts in this topic

#1 ·  Posted (edited)

I am using Koda to create a GUI for me but the pictures (jpeg, gif) arent showing up, even in samples like "About Box".

How can I fix it?

CODE
#include <ButtonConstants.au3>

#include <GUIConstantsEx.au3>

#include <StaticConstants.au3>

#include <WindowsConstants.au3>

#Region ### START Koda GUI section ### Form=

$Form4 = GUICreate("About", 324, 234, 303, 219)

GUISetIcon("D:\006.ico")

$GroupBox1 = GUICtrlCreateGroup("", 8, 8, 305, 185)

$Image1 = GUICtrlCreatePic("C:\Pics\test.gif", 16, 24, 105, 153, BitOR($SS_NOTIFY,$WS_GROUP,$WS_CLIPSIBLINGS))

$Label1 = GUICtrlCreateLabel("Product Name", 152, 24, 72, 17, $WS_GROUP)

$Label2 = GUICtrlCreateLabel("Version", 152, 48, 39, 17, $WS_GROUP)

GUICtrlCreateGroup("", -99, -99, 1, 1)

$Button1 = GUICtrlCreateButton("&OK", 128, 208, 75, 25)

GUISetState(@SW_SHOW)

#EndRegion ### END Koda GUI section ###

While 1

$nMsg = GUIGetMsg()

Switch $nMsg

Case $GUI_EVENT_CLOSE

Exit

EndSwitch

WEnd

Edited by hendrikhe

Share this post


Link to post
Share on other sites



Works without BitOR

Share this post


Link to post
Share on other sites

Thnx, it works:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0