Sign in to follow this  
Followers 0
frankzappa

Screen_Capture doesn't save any files

8 posts in this topic

Hi all,

i've checked all topics on ScreenCapture and it seems that no one has this problem i'm having here. To simplify the matter, the script

CODE

#include <ScreenCapture.au3>

_ScreenCapture_Capture("c:\teste.bmp")

doesn't create the file teste.bmp. Ive checked if _ScreenCapture_Capture was returning something by doing this

CODE
#include <ScreenCapture.au3>

global $var

$var = _ScreenCapture_Capture("")

MsgBox(0, "hohoho", $var)

and checked that something different from 0 was being returned by the function. I've tried everything from using other functions like CaptureWnd, the GDIPlus functions,

CODE
#include <GDIPlus.au3>

#include <WinAPI.au3>

#include <ScreenCapture.au3>

global $var, $hImage

_GDIPlus_Startup()

$var = _ScreenCapture_Capture("")

$hImage = _GDIPlus_BitmapCreateFromHBITMAP ($var)

_GDIPlus_ImageSaveToFile ($hImage, @ScriptDir & "\teste.bmp")

MsgBox(0, "hohoho", $var)

_GDIPlus_ImageDispose ($hImage)

_WinAPI_DeleteObject ($handleWND)

_GDIPlus_Shutdown()

MsgBox(0, "hohoho", $var)

but nothing's working. I work under XP SP2.

I had to make some changes on ScreenCapture.au3 (delcare some variables) and GDIPlus.au3 (the return error problems, explained in another topic) so that the script could launch.

Does anyone imagine why the hell nothing's working?....thanks for the help

Share this post


Link to post
Share on other sites



CODE

#include <ScreenCapture.au3>

_ScreenCapture_Capture("c:\teste.bmp")

Welcome to the AutoIt forums :)

Works fine for me. Are you sure that no file is created?


Serial port communications UDF Includes functions for binary transmission and reception.printing UDF Useful for graphs, forms, labels, reports etc.Add User Call Tips to SciTE for functions in UDFs not included with AutoIt and for your own scripts.Functions with parameters in OnEvent mode and for Hot Keys One function replaces GuiSetOnEvent, GuiCtrlSetOnEvent and HotKeySet.UDF IsConnected2 for notification of status of connected state of many urls or IPs, without slowing the script.

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Welcome to the AutoIt forums :)

Works fine for me. Are you sure that no file is created?

Hey, thanks for helping. But no, it doesn't create the file. Do Autoit have any imcompatibility with some Antivirus, other soft, etc?

Do i have to make any other modifications on the libraries? I've just changed the problems that appeared when i was compiling the script...

Edited by frankzappa

Share this post


Link to post
Share on other sites

What version of Autoit are you using?

Mine is 3.2.10.0 and it works just fine

Mine is the last one too.

I'm taking a look on the code, in GDIPlus it calls a dll called GDIPLus.dll all the time. I've checked, it's in my system32 directory, but this reminds me of another problem i had.

When i was first running the scripts it couldn't find the include files. I had to copy the hole directory "include" to the "examples" (where i'm working). Maybe there's a problem in finding the path to things?...

Maybe what i'm saying is just nonsense, but ive been working on this one for the last days, i'm aiming to anything that moves...

Cheers

Share this post


Link to post
Share on other sites

Mine is the last one too.

I'm taking a look on the code, in GDIPlus it calls a dll called GDIPLus.dll all the time. I've checked, it's in my system32 directory, but this reminds me of another problem i had.

When i was first running the scripts it couldn't find the include files. I had to copy the hole directory "include" to the "examples" (where i'm working). Maybe there's a problem in finding the path to things?...

Maybe what i'm saying is just nonsense, but ive been working on this one for the last days, i'm aiming to anything that moves...

Cheers

Hohoho, i've checked my version of Autoit...3.2.8

i installed the last one, everything works fine. Sorry for taking your time..thanks again!

Share this post


Link to post
Share on other sites

Where can I find the ScreenCapture.au3? It is not with my include files

Share this post


Link to post
Share on other sites

Where can I find the ScreenCapture.au3? It is not with my include files

Donwload the latest version of autoIt and i think it should be there, in the include folder

[quote]Don't expect for a perfect life ... Expect a least troubles ones[/quote]Contact me : ass@kiss.toWhat I Have Done :Favorites Manager Mangage your favorite's folder, that's coolPC Waker For those who want to save stickersWebScipts Supporter For those who've just started with Web and WebScriptsTemporary Looker Simple but powerful to manage your Temporary folder, you know what you downloaded[UDF] _NumberFormat() Better performance on number display[UDF] _DirGet() What a folder contain [how many (hidden,normal,...) files], with one line of code[UDF] _IsPressEs() Just like _IsPress() but for a group of keys

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0