Sign in to follow this  
Followers 0
tsno

Problem installing app in Citrix environment

1 post in this topic

Hi Guys and Gals.

Firstly can I say a big thank you to everyone on here. This is my first post but I have learned a great deal from other contributors over the past few months.

Now down to business. I'm not a programmer, I am a Citrix server admin with a 50+ server farm running PS4. I need to deploy all apps to the servers silently out of working hours and I use AutoIT to automate installs where the vendor does not provide an .msi package (the majority).

One of the issues I've found is that when Citrix Installation Manager installs a package, since there is no console session on the server, commands like winwaitactive don't work though winwait works as expected. Having established that this was a limitation I have always been able to work around it.. until now. I have a script which runs a vendor's setup.exe from a network share and then proceeds to click the buttons and work through the install procedure. However, the script stops at one of the windows which requires three input boxes to be filled with text. If I run the script and then log into the server's console the window is displayed but not active. I've tried using winactivate and @SW_ENABLE but to no avail. If I log into the server first, the script completes successfully.

Does anyone have any ideas how I can get around this issue please?

Share this post


Link to post
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0