Sign in to follow this  
Followers 0
Aassdd

Where's the problem?

4 posts in this topic

#1 ·  Posted (edited)

; Login
$IE = _IECreate("http://login.ijji.com/login.nhn")
$Form = _IEFormGetObjByName($IE, "form")
$MemberID = _IEFormElementGetObjByName($Form, "memberid")
$Password = _IEFormElementGetObjByName($Form, "password")
_IEFormElementSetValue($MemberID, "asd5")
_IEFormElementSetValue($Password, "asd12345")
_IEFormSubmit($Form)

; Launch GunZ
_IENavigate($IE, "http://gunz.ijji.com/")
_IENavigate($IE, "java script:goPlay('u_gunz',%20'');")
WinWait(" Setup Wizard")
_IEQuit($IE)

IE doesn't quit but I don't know what's the problem.

Edited by Aassdd

Share this post


Link to post
Share on other sites



; Login
$IE = _IECreate("http://login.ijji.com/login.nhn")
$Form = _IEFormGetObjByName($IE, "form")
$MemberID = _IEFormElementGetObjByName($Form, "memberid")
$Password = _IEFormElementGetObjByName($Form, "password")
_IEFormElementSetValue($MemberID, "asd5")
_IEFormElementSetValue($Password, "asd12345")
_IEFormSubmit($Form)

; Launch GunZ
_IENavigate($IE, "http://gunz.ijji.com/")
_IENavigate($IE, "java script:goPlay('u_gunz',%20'');")
WinWait(" Setup Wizard")
_IEQuit($IE)

IE doesn't quit but I don't know what's the problem.

By default _IEnavigate() calls _IELoadWait() and waits for the page to complete before continuing. Some java scripts run in a loop and the page is never "done" in the sense that _IELoadWait() will continue. Try adding the $fWait = 0 option to your last _IENavigate().

:)


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

It worked, you are right. Another question, I get this in output (on all navigate lines)

--> IE.au3 V2.3-1 Warning from function _IELoadWait, $_IEStatus_AccessIsDenied (Cannot verify readyState. Likely casue: cross-site scripting security restriction.)

What is it? It seems a loadwait error but it works.

Edited by Aassdd

Share this post


Link to post
Share on other sites

Are there frames or iFrames?

Likely casue: cross-site scripting security restriction

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0