Jump to content
Sign in to follow this  
nitron

ADfunctions

Recommended Posts

nitron

Hy,

I know there been many q/a about this seemingly wonderfull tool AdFunctions.au3

I've been able to get the hang of it ... i thought...

My Problem is :

1.) I was able to create a User :

_ADCreateUser("CN=Users,DC=Domain,DC=Domain2", "UserLogin", "FirstName", "LastName","Discription")

2.) I was able to create a Group :

_ADCreateGroup("CN=Users,DC=Domain,DC=Domain", "GroupName")

so far so good!

Then I tried the the 3rd function!

_ADAddUserToGroup

but I always get an error.

According to the ADFunctions fiel the syntax schould be :

_ADAddUserToGroup("Groupname","UserLogin")

but it won't work...

At first, i searched the Forum an found hundreds of post, with unanswered questions... Is this a ignored AU3 or am getting something defently wrong?!

Since i could seem to find a proper answer with in the forum i went for trying...

I tried :

_ADAddUserToGroup("CN=Groupname","CN=UserLogin")

_ADAddUserToGroup("CN=GroupnameCN=Users","CN=UserLoginCN=Users")

_ADAddUserToGroup("CN=Groupname,CN=Users,DC=Domain,DC=Domain2"","CN=UserLogin,CN=Users,DC=Domain,DC=Domain2")

this wouldn't work either... What am I doing worng? Please i don't get it

Thanks for youre Help in advance!

Martin

Edited by nitron

Share this post


Link to post
Share on other sites
nitron

I would be happy with any Informations

Share this post


Link to post
Share on other sites
Cyri

I know this is old, but see my response on THIS thread. It may answer your question.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×