Sign in to follow this  
Followers 0
Champak

Send() getting garbled

2 posts in this topic

I'm trying to use Send() to send text to another application. I tried controlsend and controlsetteext, but they just wont work at all. Send() is communicating, but not properly. Ex. if $blah = "Conner Romp" and I do Send($blah), the text sent to the app would turn out as "oR nnecrpom". Just an example, may not be exact sequence of lettering...but it isn't exactly reversed. Has anyone ever seen this?

Share this post


Link to post
Share on other sites



I'm trying to use Send() to send text to another application. I tried controlsend and controlsetteext, but they just wont work at all. Send() is communicating, but not properly. Ex. if $blah = "Conner Romp" and I do Send($blah), the text sent to the app would turn out as "oR nnecrpom". Just an example, may not be exact sequence of lettering...but it isn't exactly reversed. Has anyone ever seen this?

Are there characters in the string that would trigger metakeys (i.e. !, +, ^, #)? If so, use ControlSend() with the "raw flag" set.

:D


Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0