Sign in to follow this  
Followers 0
Info

Three _IE questions...

9 posts in this topic

#1 ·  Posted (edited)

1. How do I connect between the load of the internet page and between a progress bar?

2. How do I get the current page's title / HTML code?

3. How do I get the picture buttons in my GUI to not be looked like buttons so when you click on it it looks like you click on the picture? (for now I'm using the $BS_ICON style for the button)

Thank you :D

Edited by Info

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

1. How do I connect between the load of the internet page and between a progress bar?

You don't, because it requires you to psychically divine what the finished size of the page is before you have downloaded all of it. Because so much of a modern web page is dynamic there is no way to know ahead of time how much more you are waiting for. This makes an accurate progress bar a lost cause, in my opinion. That changes if it is a particular page that is fairly static over time and you know something about.

2. How do I get the current page's title / HTML code?

_IEPropertyGet($oIE, "title") / _IEDocReadHTML() -- Both in the help file.

3. How do I get the picture buttons in my GUI to not be looked like buttons so when you click on it it looks like you click on the picture?

Not sure.

Hey, 1 out of 3 ain't bad for a batting average...

:D

Edited by PsaltyDS

Valuater's AutoIt 1-2-3, Class... Is now in Session!For those who want somebody to write the script for them: RentACoder"Any technology distinguishable from magic is insufficiently advanced." -- Geek's corollary to Clarke's law

Share this post


Link to post
Share on other sites

BUMP :D

Share this post


Link to post
Share on other sites

AGAIN :D

Share this post


Link to post
Share on other sites

Since you asked short, ambiguous questions with little or no detail, that's the kind of answers you'll get.

1) See the helpfile for ObjEvent in the Obj/COM reference section for some information

2) you got an answer

3) I really have no idea what you mean

I don't suggest asking groups us seemingly unrelated questions in one post.

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Since you asked short, ambiguous questions with little or no detail, that's the kind of answers you'll get.

1) See the helpfile for ObjEvent in the Obj/COM reference section for some information

2) you got an answer

3) I really have no idea what you mean

I don't suggest asking groups us seemingly unrelated questions in one post.

Dale

I can't get the function over there to work with my progress bar...

And about the third question:

I want this button:

Posted Image

To look like this:

Posted Image

Do you know what I mean now?

Edited by Info

Share this post


Link to post
Share on other sites

Please put yourself in the place of the people you are asking for help. You leave far too many things open for assumption and I won't try to answer every question you could potentially be asking.

You'll need to describe a lot more about 1) and share code and webpage info to get any help.

In 3), when you talk about GUI do you mean an AutoIt GUI or are you talking about a webpage?

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

AutoIt GUI,

the code of the button with the .bmp image is

$Button = GUICtrlCreateButton("", 776, 47, 63, 23, $BS_BITMAP)
GUICtrlSetImage (-1, "images.bmp", 0)

And two more questions:

1. How can I get the website's URL to my Input/Combo everytime I click on something that takes me to a different URL? (link / Main GUI's button)

2. How can I GUICtrlSetData($Label,"Loading...") everytime a page loads?

Edited by Info

Share this post


Link to post
Share on other sites

BUMP :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0