Jump to content
Sign in to follow this  
Info

_IE Problems :(

Recommended Posts

Info

1. How can I get the website's URL to my Input/Combo everytime I click on something that takes me to a different URL? (link / Main GUI's button)

2. How can I do GUICtrlSetData($Label,"Loading...") everytime a page loads?

3. How can I connect between a page load and between a progress bar? (GUI's progress)

4. When send a $GUI_EVENT_CLOSE message, the program wont exit until the internet page is done loading... Solution?

5. I got some buttons with pictures in my GUI, but they still look like buttons,

So how can I hide a button's texture so when I see it and when I click it, it will look like this:

Posted Image

And NOT look like this:

Posted Image

Thanks :D

Edited by Info

Share this post


Link to post
Share on other sites
DaleHohm

It didn't work the last time because you asked poor questions, you gave very little information, your post title says it is about IE but your questions appear to be about the AutoIt GUI, you put too many unrelated questions together in the same post, you showed no code that you've tried and then you started bumping the post.

Now you've repeated it. Think your results are gonna get better?

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
nobbe

most answers can be found in help files or in the forum

answers

all assuming you are using the IE object for browsing

1) just extract title from webpage ??

2) just set it in your script when you load it ??

3) from autoit help file

CODE

ProgressOn("Example", "Loading page...")

$oIE=ObjCreate("InternetExplorer.Application.1") ; Create Internet Explorer application

$SinkObject=ObjEvent($oIE,"IEEvent_","DWebBrowserEvents2") ; Assign events to UDFs starting with IEEvent_

; Do some browsing activities

$oIE.Visible=1

$oIE.RegisterAsDropTarget = 1

$oIE.RegisterAsBrowser = 1

$oIE.Navigate( "http://www.AutoItScript.com/" )

sleep(3000) ; Give it time to load the web page

$SinkObject=0 ; Stop IE Events

$oIE.Quit ; Quit IE

$oIE=0

exit

; one of many Internet Explorer Event Functions

Func IEEvent_ProgressChange($Progress,$ProgressMax)

$percent = Int( ($Progress * 100) / $ProgressMax )

If $percent >= 0 And $percent <= 100 Then

ProgressSet ( $percent , $percent & " percent to go." , "loading web page" )

EndIf

EndFunc

Exit

4) no, the gui waits for the event to load finish

5) setup a picture , not a button control - use hittest with mouse click 1 if the mouse coords are within dimensions of the picture (i saw samples of that in the forum)

Share this post


Link to post
Share on other sites
GEOSoft

1. How can I get the website's URL to my Input/Combo everytime I click on something that takes me to a different URL? (link / Main GUI's button)

2. How can I do GUICtrlSetData($Label,"Loading...") everytime a page loads?

3. How can I connect between a page load and between a progress bar? (GUI's progress)

4. When send a $GUI_EVENT_CLOSE message, the program wont exit until the internet page is done loading... Solution?

5. I got some buttons with pictures in my GUI, but they still look like buttons,

So how can I hide a button's texture so when I see it and when I click it, it will look like this:

Posted Image

And NOT look like this:

Posted Image

Thanks :D

I agree with Dale. Not enough info has been given. If I read between the lines I think that what you want is to add the $BS_FLAT style to your buttons.

George

Question about decompiling code? Read the decompiling FAQ and don't bother posting the question in the forums.

Be sure to read and follow the forum rules. -AKA the AutoIt Reading and Comprehension Skills test.***

The PCRE (Regular Expression) ToolKit for AutoIT - (Updated Oct 20, 2011 ver:3.0.1.13) - Please update your current version before filing any bug reports. The installer now includes both 32 and 64 bit versions. No change in version number.

Visit my Blog .. currently not active but it will soon be resplendent with news and views. Also please remove any links you may have to my website. it is soon to be closed and replaced with something else.

"Old age and treachery will always overcome youth and skill!"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×